Opening attachments from a received e-mail leaves a copy of that attachment on the desktop

RESOLVED DUPLICATE of bug 311292

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 311292
7 years ago
7 years ago

People

(Reporter: terryD, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_5_8; en-us) AppleWebKit/533.18.1 (KHTML, like Gecko) Version/5.0.2 Safari/533.18.5
Build Identifier: Thunderbird/3.1.5

Starting with TBird 3.1.1 thru 3.1.5 double-clicking to open attachments from within a received e-mail leaves a copy of that attachment on the desktop. The copy remains after closing both the application used to open the attachment and TBird as well. In the attachment Preferences window Always ask me where to save Radio button is SELECTED. Save files to (folder) is deselected but defaulted to Desktop. Buy selecting Save files to Radio button the location of the deposited attachment can be moved to any folder selected whether the Radio button is selected or not. The second part of the problem is that the opened attachment is automatically copied in the folder location associated with Save Files to Radio button and is NOT deleted upon closing TBird. This has happened with Word, Excel, PowerPoint, and Preview apps used to open different attached files.

Reproducible: Always

Steps to Reproduce:
1. open email with attachment
2 [review]. double-click on attachment
3 [review]. hide TBird and find attached file on Desktop
4. Close attached file and app ... copied attachment remains on Desktop
5. Close TBird ... copied attachment remains on Desktop

Actual Results:  
It's pretty obvious from the above descriptions that attachments to email messages that are double-clicked to open from within TBird are being copied to the location shown in Attachment Preferences for the Save Files to Location whether the Radio button is selected or not.

Expected Results:  
My expectation is that most would double-click to review the content of the attached file. Should they wish to keep it for themselves they could Save them through the Save Attachment protocal. IF they choose not to keep the attachment the file should remain embedded in the email when closing either the source Application or Tbird and not arbitrarily copied to a location on the individuals hard drive.

I've reported this "Bug" because the info associated with 575875 does not cover this sequence of events. Something in the code is telling Thunderbird to save any attachment to the location shown in Preferences for Save File To, even though the radio button is deselected, when the individual double-clicks on the attachment. I have made new folders for the Save Files To location then deselected the radio button choosing Always Ask and copies of the attachment will always go to the identified folder for Save Files To
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 311292
You need to log in before you can comment on or make changes to this bug.