Investigate reports of Yahoo toolbar not working after Firefox 3.6.11 upgrade

RESOLVED INVALID

Status

()

RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: christian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
Some users are complaining that the yahoo toolbar stopped working after the 3.6.11 update:

https://support.mozilla.com/en-US/questions/759554

This bug will track the investigation to see if it is their problem or our own. Off the top of my head I can't think of any changes that would have impacted it.
(Reporter)

Comment 1

8 years ago
Looks like most reports are on Windows XP...
OS: Mac OS X → Windows XP
(Reporter)

Comment 4

8 years ago
I'm unable to reproduce on Win7 going from 3.6.10 -> 3.6.11
I just used XP SP3 with 3.6.10, installed current toolbar, viewed it as functional, upgraded to 3.6.11, and continued to use the toolbar.
(Reporter)

Updated

8 years ago
Blocks: 606336
(Reporter)

Comment 6

8 years ago
https://support.mozilla.com/en-US/questions/759914
https://support.mozilla.com/en-US/questions/759912

Note that a new toolbar was released the 18th, so this could possibly be:

1. An old bug that is fixed with the most recent toolbar, only people with the old toolbar are hitting the issue
2. A new issue introduced with the most recent Yahoo toolbar release, the timing of 3.6.11 is merely a coincidence
3. An issue introduced in 3.6.11, firefox's fault
4. An issue introduced in 3.6.11, Yahoo toolbar is doing something wrong/unsupported/insecure we clamped down on
5. Something else entirely (AV? other toolbars?)

Also note I see behavior similar to what people are describing on trunk (where we expect the toolbar to likely not work, bug 606336). This is with the same Win7 system, FF profile, and Yahoo toolbar that I could not reproduce with on branch builds in comment 4.
I just tried with version 2.1.2.20100119091315 of the Yahoo Toolbar (which is what we offer on AMO at https://addons.mozilla.org/en-US/firefox/addon/2032/). This is from January.

It works on 3.6.10 on XP SP3 and continues to work after upgrade to 3.6.11.

Comment 8

8 years ago
Al, what did you try?  The toolbar shows up but some functions don't work or going to certain yahoo pages while logged in, the pages load funny/broken/don't load.
I clicked on the buttons on the toolbar and saw the various pages load.
Can you detail what, specifically, is broken? What version of the toolbar are you using?

Comment 11

8 years ago
I don't know, these are reports from users.  

Yahoo! Toolbar 2.1.2.20100119091315 true {635abd67-4fe9-1b23-4f01-e679fa7484c1} from about:support for one user.

Comment 12

8 years ago
actually... this may be a weird "false" alarm.  Per https://support.mozilla.com/en-US/questions/759554 if you just log out of yahoo and come back after a few days, it works again?  I'm asking people to clear cookies and try again.
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.