[D2D] Fix brushes for transformed strokes

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: bas, Assigned: bas)

Tracking

unspecified
x86
Windows 7
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
Created attachment 485192 [details] [diff] [review]
Properly inverse transform the brush

In Direct2D for transformed strokes we apply the inverse transform to the path and then the transform to the render target. This ensures the transform is applied to strokestyle as well. When doing this we neglect to also inverse transform the brush, which is needed to ensure correct positioning.

This should get a reftest too! But I suggest we get the fix in quickly.
Attachment #485192 - Flags: review?(jmuizelaar)
Attachment #485192 - Flags: review?(jmuizelaar) → review+
(Assignee)

Updated

7 years ago
Duplicate of this bug: 615600
(Assignee)

Updated

7 years ago
Duplicate of this bug: 615176
(Assignee)

Comment 3

7 years ago
This should probably block final.
blocking2.0: --- → ?
Do want a reftest
blocking2.0: ? → final+
(Assignee)

Comment 5

7 years ago
http://hg.mozilla.org/mozilla-central/rev/824f8a023254

Keeping this open for a reftest
I can offer a free reftest that's already in the tree! This patch made reftest/tests/layout/reftests/svg/text-gradient-03.svg pass on Windows Opt so if you change the reftest/tests/layout/reftests/svg/reftest.list and remove the random_if(winWidget) bit, you're done.
Blocks: 614324
Please file a followup for fixing the reftest - or, better yet, just check in the fix!
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.