Gmail and archiving(when you read a message in thunderbird it still keeps the archived message as unread)

RESOLVED DUPLICATE of bug 693204

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 693204
7 years ago
4 years ago

People

(Reporter: chobojunk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.11) Gecko/20101013 Thunderbird/3.1.5

It seems when you have a gmail account set with imap and you get a new unread message and read the message it will still be unread in the archived section. So when a new message comes in the notifier will show 2 unread messages when in reality you only have 1 unread message.

Reproducible: Always

Steps to Reproduce:
1. Have a gmail account with imap
2. Send a email to this account
3. Click on it and read the email
4. Check the archive section(this email will still be bold for unread)


Expected Results:  
Once you read a email it should be marked as unread in all areas.
(In reply to comment #0)
> So when a new message comes in the notifier will show 2 unread messages when in reality you only have 1 unread message.

For IMAP client, mail in Inbox and mail in [Gmail]/All Mail are absolutely different mail(different UID in different IMAP folder), even though single mail data instance is really held by Gmail. They are similar to two mail copies in Inbox of Local Folders and other folder of Local Folders for mail client.
=> Invalid.
If you already know that Gmail IMAP shows copy of a mail in [Gmail]/All Mail, stop needless new mail check of [Gmail]/All Mail.
Read Gmail's help documents which are required to read and understand before you start to use Gmail IMAP, prior to adding complaints at B.M.O, please. Read all bugs listed in dependency tree for meta bug 402793 with show resolved.

> Expected Results:  
> Once you read a email it should be marked as unread in all areas.

If you opened "[Gmail]/All Mail" when you marked a mail Unread a Inbox, and if you enable IDLE, dup of bug 512745. See also bugs listed in dependency tree for the bug 512745.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 512745
"IDLE does not send unsolicited responses for flag changes" is not Gmail IMAP only issue.
Issue of "Tb is not torelant with 'IDLE does not send unsolicited responses for flag changes'" is not Gmail IMAP only issue.
Because bug 693204 was processed after analysis of many bugs, that bug is crispy than other bugs.
So, duping this bug to bug 693204.
If duping is wrong, re-open this bug, please.
Duplicate of bug: 693204
You need to log in before you can comment on or make changes to this bug.