Tools > Addons disables or breaks usual web page interaction behaviors

VERIFIED INVALID

Status

()

Toolkit
Add-ons Manager
VERIFIED INVALID
8 years ago
8 years ago

People

(Reporter: skierpage, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre) Gecko/20101021 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b8pre) Gecko/20101021 Firefox/4.0b8pre

It's fine to move windows into Firefox, but it sucks that most subpages of Tools > Addons look like a web page yet lack most of the goodness of web pages.  Here's a partial list:

* No fragment identifiers as you move around within the subpages.  Why not about:addons#appearance and about:addons#plugins;Google%20Talk%20Plugin ?
* You can bookmark about:addons, but because there's no fragment identifier, it's pointless.
* about:addons has duplicated back & forward buttons _within_ the page, which is madness!
* Because there's no change in page title or fragment identifier, nothing changes as you use either set of back & forward buttons, and the history in the proper back & forward buttons only repeats "Add-ons Manager" and "about:addons".
* You can't select and copy text.  Oh joy, I get to hand type "Google Talk Plugin Video Accelerator version:0.1.43.3" into another window.
* Links don't preview.  Some links go to other subpages of about:addons , but e.g. Extension author names like Joe Hewitt do go to regular web pages and there's no way to tell.
* The regular Firefox context menu on links and text is missing.
* No View Source.

about:addons is not even internally consistent; parts of the Get Add-ons subpage _do_ work like a proper web page with selectable text, URL preview, the normal context menu, etc.

Is there a spec that says in-browser "pages" should behave this way?  It doesn't seem thought through, and now other elements of Firefox like Mozilla Labs Test Pilot and Grafx Bot seem to be heading the same, wrong, way.

Reproducible: Always

Steps to Reproduce:
1. Bring up Tools > Add-ons
2. Interact with it as you would with other web pages.
Actual Results:  
See above.  about:addons behavior is different, except for parts of the Get Add-ons section.

Expected Results:  
It looks like a web app in a web page, so it should work like a web app in a web page.  about:plugins, about:support, etc. don't suffer from these problems.

I'm being harsh on the non-webness, but I'm happy with the layout and features of Tools > Add-ons.
This is really a large collection of bugs which aren't useful for development so I'm just going to comment on each of the points, suggest opening single bugs where relevant and then close this.

> * No fragment identifiers as you move around within the subpages.  Why not
> about:addons#appearance and about:addons#plugins;Google%20Talk%20Plugin ?

This is certainly a possibility for the future though I'm not sure how useful it'd actually end up being. Please file a bug on it.

> * You can bookmark about:addons, but because there's no fragment identifier,
> it's pointless.

Part of the above really.

> * about:addons has duplicated back & forward buttons _within_ the page, which
> is madness!

This is bug 597178

> * Because there's no change in page title or fragment identifier, nothing
> changes as you use either set of back & forward buttons, and the history in the
> proper back & forward buttons only repeats "Add-ons Manager" and
> "about:addons".

This isn't the case for me, back/forward takes you back and forward as I would expect. If you are seeing problems please file a bug with steps to reproduce.

> * You can't select and copy text.  Oh joy, I get to hand type "Google Talk
> Plugin Video Accelerator version:0.1.43.3" into another window.

This is something that has been discussed at length, see for example bug 246400 and bug 601640. As this is really meant to be considered UI I don't think we're really decided on the right solution (we never did for the old add-ons manager either).

> * Links don't preview.  Some links go to other subpages of about:addons , but
> e.g. Extension author names like Joe Hewitt do go to regular web pages and
> there's no way to tell.

bug 603236

> * The regular Firefox context menu on links and text is missing.

Similar issue to selecting text.

> * No View Source.

View source works for me, I can see the XUL that is building the UI just fine. I can't see the actual contents of the UI but then the same is true of any rich webapp like Gmail.

> about:addons is not even internally consistent; parts of the Get Add-ons
> subpage _do_ work like a proper web page with selectable text, URL preview, the
> normal context menu, etc.

We're likely to change that in bug 571606. It appears to work as a normal webpage because it actually is a normal webpage.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(In reply to comment #1)
> > * Because there's no change in page title or fragment identifier, nothing
> > changes as you use either set of back & forward buttons, and the history in the
> > proper back & forward buttons only repeats "Add-ons Manager" and
> > "about:addons".

This is the result from not showing the fragment of the AOM page. Once this is fixed this will be automatically fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.