crash [@ nsRefPtr<nsIDOMEventListener>::assign_with_AddRef(nsIDOMEventListener*) | mozilla::layers::PlanarYCbCrImageD3D10::PlanarYCbCrImageD3D10(mozilla::layers::LayerManagerD3D10*) ]

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: scoobidiver, Assigned: bas.schouten)

Tracking

({crash, regression})

Trunk
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Build: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101021 Firefox/4.0b8pre

It is a new crash signature that first appeared in b8pre/20101020 build.
Build            Rank
b8pre/20101020 : #52
b8pre/20101021 : #16

Signature	nsRefPtr<nsIDOMEventListener>::assign_with_AddRef(nsIDOMEventListener*) | mozilla::layers::PlanarYCbCrImageD3D10::PlanarYCbCrImageD3D10(mozilla::layers::LayerManagerD3D10*)
UUID	b714ec08-d9ef-4621-883f-60fe92101021
Time 	2010-10-21 10:41:05.917022
Uptime	10438
Last Crash	2163534 seconds (3.6 weeks) before submission
Install Age	13778 seconds (3.8 hours) since version was first installed.
Product	Firefox
Version	4.0b8pre
Build ID	20101021042123
Branch	2.0
OS	Windows NT
OS Version	6.1.7601 Service Pack 1, v.178
CPU	x86
CPU Info	AuthenticAMD family 17 model 3 stepping 1
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x2e0073
App Notes 	AdapterVendorID: 1002, AdapterDeviceID: 9612

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsRefPtr<nsIDOMEventListener>::assign_with_AddRef 	obj-firefox/dist/include/nsAutoPtr.h:940
1 	xul.dll 	mozilla::layers::PlanarYCbCrImageD3D10::PlanarYCbCrImageD3D10 	gfx/layers/d3d10/ImageLayerD3D10.cpp:219
2 	xul.dll 	mozilla::layers::ImageContainerD3D10::CreateImage 	gfx/layers/d3d10/ImageLayerD3D10.cpp:62
3 	xul.dll 	VideoData::Create 	content/media/nsBuiltinDecoderReader.cpp:132
4 	xul.dll 	nsWebMReader::DecodeVideoFrame 	content/media/webm/nsWebMReader.cpp:669
5 	xul.dll 	nsBuiltinDecoderStateMachine::DecodeLoop 	content/media/nsBuiltinDecoderStateMachine.cpp:276
6 	xul.dll 	nsRunnableMethodImpl<void 	obj-firefox/dist/include/nsThreadUtils.h:347
7 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:547
8 	xul.dll 	nsThread::ThreadFunc 	xpcom/threads/nsThread.cpp:263
9 	nspr4.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:426
10 	nspr4.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:122
11 	mozcrt19.dll 	_callthreadstartex 	obj-firefox/memory/jemalloc/crtsrc/threadex.c:348
12 	mozcrt19.dll 	_threadstartex 	obj-firefox/memory/jemalloc/crtsrc/threadex.c:326
13 	kernel32.dll 	BaseThreadInitThunk 	
14 	ntdll.dll 	__RtlUserThreadStart 	
15 	ntdll.dll 	_RtlUserThreadStart 	

The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c9df0c5cbf8c&tochange=7aa9763e9d41
It seems to be a consequence of the fixing of bug 603071.

Some reports at:
http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=&date=10%2F21%2F2010%2023%3A53%3A26&range_value=1&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=nsRefPtr%3CnsIDOMEventListener%3E%3A%3Aassign_with_AddRef%28nsIDOMEventListener*%29%20|%20mozilla%3A%3Alayers%3A%3APlanarYCbCrImageD3D10%3A%3APlanarYCbCrImageD3D10%28mozilla%3A%3Alayers%3A%3ALayerManagerD3D10*%29
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
(Assignee)

Updated

8 years ago
Assignee: nobody → bas.schouten
Status: NEW → ASSIGNED
blocking2.0: ? → final+
(Assignee)

Comment 1

8 years ago
Created attachment 485739 [details] [diff] [review]
Remove ContainerD3D10 dependencies on Manager

I believe this is the most elegant solution. At container creation the container will grab a reference to the threadsafe D3D10 device. It will never have any other dependencies on the manager.
Attachment #485739 - Flags: review?(roc)
(Assignee)

Updated

8 years ago
Duplicate of this bug: 606475
(Assignee)

Comment 3

8 years ago
http://hg.mozilla.org/mozilla-central/rev/c7c309313eb3
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Crash Signature: [@ nsRefPtr<nsIDOMEventListener>::assign_with_AddRef(nsIDOMEventListener*) | mozilla::layers::PlanarYCbCrImageD3D10::PlanarYCbCrImageD3D10(mozilla::layers::LayerManagerD3D10*) ]
You need to log in before you can comment on or make changes to this bug.