If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

'Close other tabs' opens unwanted preview pane

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: Niall Leonard, Unassigned)

Tracking

(Blocks: 1 bug)

x86_64
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/534.3 (KHTML, like Gecko) Chrome/6.0.472.63 Safari/534.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.11) Gecko/20101013 Thunderbird/3.1.5

I have Tab View is enabled for emails and I have more than two open.  I want to close all the other tabs and go back to my overview.   I right-click on the leftmost tab and all the other tabs close, yes, but then the Preview Pane opens. I hate the Preview window, I never use it. 

I press F8 to close the preview pane.  It does not close.  The preview advances to the previous message.

I press F8 again.  Now the preview pane closes.  This is inconsistent behaviour by the F8 key.

  

Reproducible: Always

Steps to Reproduce:
1. Open more than two emails in more than two tabs.
2. Right-click on the leftmost tab.  Choose 'Close Other tabs'
3. Other tabs close, preview pane opens.
4. Press F8 to close preview pane.  It doesn't work.
Actual Results:  
Preview pane appeared without being requested.

Expected Results:  
Back to Folder overview with one tab visible referring to currently highlighted message, and no preview. 

No theme being used.  Behaviour noted on two different machines, one running Vista, the other W7.
(Reporter)

Updated

7 years ago
OS: Windows 7 → Windows XP
Version: unspecified → 3.1
WFM (TB 20101013 3.3a1pre)

Niall could you try with extensions disabled? See how-to can start TB in safe-mode here http://support.mozillamessaging.com/bg/kb/Safe+Mode
(Reporter)

Comment 2

7 years ago
It still happens in Safe Mode.

However I notice that if the leftmost Tab is made active and THEN you right click on it and choose 'close other tabs' the other tabs vanish and no Preview Pane appears.  So the problem only occurs if one of the tabs to the right is the active one. 

When the Preview Pane does appear the action of F8 is still inconsistent.
(In reply to comment #2)
> However I notice that if the leftmost Tab is made active and THEN you right
> click on it and choose 'close other tabs' the other tabs vanish and no Preview
> Pane appears.  

Yes, now I can confirm: still exists also in TB 3.3a1pre.

STR:

0. set preview pane off;
1. Open more than two emails in more than two tabs.
2. Right-click on the leftmost tab *without select* and choose 'Close Other tabs' from context menu
3. Other tabs close, preview pane opens.

Thanks for your feedback!
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

7 years ago
Confirmed on TB 3.1.7. Annoying but cute :)
Blocks: 392328
Component: General → Mail Window Front End
QA Contact: general → front-end

Comment 5

6 years ago
Confirmed on TB 3.1.15 as well, I don't want to use the preview pane either, hate that this happens. 

Additional info, when this happens, the "Message Pane" option in the menu is not checked and you have to press F8 twice to make it disappear. Also the pane doesn't work as it should, it shows the last email you opened before closing the tabs and does not switch to the message you click on. It only happens when you do not switch tabs after opening the last message, and then right click on the main tab to close other tabs. If you switch to one of the other email tabs or the main tab before selecting 'close other tabs', this doesn't happen, and when it does and you open another email it will disappear.
I cannot reproduce this on WinXP, TB17.0.8, using exact steps of comment 0 on Pop3 inbox folder.

For ease of workflow, I'll close this worksforme.

Please do reopen this bug if you are able to reproduce it under any circumstances, and please provide exact details of those circumstances and steps.

Otherwise confirmation of wfm or "verified" wfm would be appreciated.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.