sync-response href triggering "malformed URI sequence"

RESOLVED DUPLICATE of bug 465853

Status

Calendar
Provider: CalDAV
RESOLVED DUPLICATE of bug 465853
7 years ago
3 years ago

People

(Reporter: Axel Naumann, Unassigned)

Tracking

Details

(Whiteboard: [calconnect31])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.11) Gecko/20101013 Ubuntu/10.10 (maverick) Firefox/3.6.11
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.11) Gecko/20101006 Lightning/1.0b2 Thunderbird/3.1.5

One of my calendar entries looked like this:
 <sync-response>
  <href>/caldav.php/axel/home/20100811T205615Z-uidGen%40fe8000021321fffeb04b6e%252.ics</href>
  <status>HTTP/1.1 201 Created</status>
  <propstat>
   <prop>
    <getcontenttype>text/calendar</getcontenttype>
    <getetag>"0882950280cdc67eb37e1d3e50644e9f"</getetag>
    <C:calendar-data>BEGIN:VCALENDAR

...
</C:calendar-data>
   </prop>
   <status>HTTP/1.1 200 OK</status>
  </propstat>
 </sync-response>

(as reported by wireshark).

Putting it into the calendar will trigger
Error: malformed URI sequence
Source File: file:///home/axel/.thunderbird/myan007a.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/axel/.thunderbird/myan007a.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavCalendar.js
Line: 833

Warning: CalDAV: Fatal Error doing webdav sync for Rauterli

Error: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsISAXXMLReader.onDataAvailable]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: file:///home/axel/.thunderbird/myan007a.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/axel/.thunderbird/myan007a.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js :: wSL_onDataAvailable :: line 482"  data: no]
Source File: file:///home/axel/.thunderbird/myan007a.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///home/axel/.thunderbird/myan007a.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calDavRequestHandlers.js
Line: 482

Removing it will make it work.

Reproducible: Always

Steps to Reproduce:
1. Add above event to calendar
2. Reload calendar

Actual Results:  
Error (see e.g. error console); none of the calendar entries are displayed.

Expected Results:  
Calendar loads without errors

My guess (from looking at calDavCalendar.js:833) is that it's caused by the (yes, weird) href. Could this decoding be made a bit more robust?

I'm using davical on the server side; it happens both via http and https.
Whiteboard: [calconnect25]
Whiteboard: [calconnect25] → [calconnect31]
Could you try the patch in bug 465853? This hardens the href encoding a little and could fix the issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 465853
You need to log in before you can comment on or make changes to this bug.