Closed Bug 606492 Opened 10 years ago Closed 10 years ago

Cannot pan language list with new theme

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set

Tracking

(fennec2.0b2+)

VERIFIED FIXED
Tracking Status
fennec 2.0b2+ ---

People

(Reporter: aakashd, Assigned: mbrubeck)

Details

Attachments

(1 file)

Build Id:
Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b8pre) Gecko/20101022 Namoroka/4.0b8pre Fennec/4.0b2pre

Steps to Reproduce:
1. Swipe to the left to open the control sidebar
2. Tap on the browser controls button
3. Tap on the button associated to the "Language" row entry within Preferences
4. Orient to portrait mode

Actual Results:
After steps 3 and 4, the list cannot be panned and it extends out past the viewable area.

Expected Results:
After steps 3 and 4, the list should be able to pan and NOT extend out past the viewable area.
tracking-fennec: --- → ?
tracking-fennec: ? → 2.0b2+
Assignee: nobody → mbrubeck
Attached patch patchSplinter Review
The "display: inline-block" on the .prompt-buttons class was preventing box sizing from working in the richlistbox.  I can't remove it from that class, because that messes with the horizontal sizing of buttons in dialogs.  Instead, this patch overrides "display" in the menulist-popup only.

Also includes some very minor selector cleanup.

I filed followup bug 606581 for a larger cleanup of this code.
Attachment #485405 - Flags: review?(mark.finkle)
Attachment #485405 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mobile-browser/rev/a49744b5e5e2
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
verified FIXED on builds:
Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b8pre) Gecko/20101025 Namoroka/4.0b8pre Fennec/4.0b2pre

and

Mozilla/5.0 (Android; Linux armv71; rv:2.0b8pre) Gecko/20101025 Namoroka/4.0b8pre Fennec/4.0b2pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.