Closed Bug 606539 Opened 12 years ago Closed 12 years ago

Report Android specific info in crash reports

Categories

(Toolkit :: Crash Reporting, enhancement)

All
Android
enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
fennec 2.0b2+ ---

People

(Reporter: mwu, Assigned: blassey)

Details

Attachments

(1 file, 2 obsolete files)

It would be nice to get Android specific info in a crash report or even just know at a glance that a crash report is for android.
The current OS field is Linux, then? Do you just want to change that to Android instead? I don't think grouping Android and Linux-desktop reports makes a lot of sense in general.

What other "Android specific info" are you talking about? Is it something that you want to be able to query on crash-stats? Reporting metadata is easy, but using it is hard.
we could also post-process that in the client, which would probably be easier
How? That data is part of the minidump, not the text file.
oh sorry, I misread ted's comment
We would also like info on the device name and build type (thumb2 or nothumb)
That we might have a harder time getting into the minidump, although we could probably report CPU features, since there's space in the CPU field where we stick CPUID data for x86.
Attached patch patch (obsolete) — Splinter Review
this sends a fair bit of extra info along as extra keys, Tt also appends the device manufacturer, device model and build figure print to the notes field since that's more readable in the crash reports. If the min cpu is less than 7 it also appends "nonthumb2 build".

Here is an example crash report with this change
http://crash-stats.mozilla.com/report/index/bp-36e1a5c0-5001-49da-a701-78d4c2101027
Assignee: nobody → blassey.bugs
Attachment #486383 - Flags: review?(ted.mielczarek)
Attachment #486383 - Flags: review?(mwu)
Comment on attachment 486383 [details] [diff] [review]
patch

All the fields in Build are static, so you don't need to instantiate a Build object.

Eliminate the extra empty line after sendPart(os, boundary, kNotesKey, notes);

Add a space after notes in the nonthumb2 build part. Lets use nothumb instead of nonthumb2 to keep naming consistency with ftp.
Attachment #486383 - Flags: review?(mwu)
Attached patch patch (obsolete) — Splinter Review
Attachment #486383 - Attachment is obsolete: true
Attachment #486459 - Flags: review?(mwu)
Attachment #486383 - Flags: review?(ted.mielczarek)
Comment on attachment 486459 [details] [diff] [review]
patch

r=me with the last comment in the last review fixed. That is, there should be a space in notes+= and s/nonthumb2/nothumb/.
Attachment #486459 - Flags: review?(mwu) → review+
Comment on attachment 486459 [details] [diff] [review]
patch

got approval for fennec b2 from Stuart over irc
Attachment #486459 - Flags: approval2.0+
Attachment #486459 - Attachment is obsolete: true
Attachment #486480 - Flags: review+
Attachment #486480 - Flags: approval2.0+
Comment on attachment 486480 [details] [diff] [review]
patch for checkin

Use carriage returns to separate the bits you're putting in the notes field. Also, can you use a more descriptive name for "Min CPU"? (also you used a space in that name where you used underscores for the rest, should probably be consistent.)

Please file a followup bug to get Socorro to display these additional fields, and put a comment above where you set the Notes field referencing it, so that we can remove that code once Socorro can display the other fields.
Attachment #486480 - Flags: review+
tracking-fennec: --- → 2.0b2+
pushed http://hg.mozilla.org/mozilla-central/rev/3369bc46ff9c and filed bug 607942
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.