Simple website to display projects and component stats

RESOLVED WONTFIX

Status

Websites
Other
RESOLVED WONTFIX
8 years ago
5 years ago

People

(Reporter: Sheila Mooney, Assigned: mcote)

Tracking

Details

(Reporter)

Description

8 years ago
This is a similar initiative to bug 606240 to create some project dashboard for monitoring metrics. This bug relates more to a PM/Manager view that helps answer some highlevel questions....

What is the rate of change on our product?

Where are we getting blocked?

Are the most important issues getting addressed?
(Reporter)

Comment 1

8 years ago
Managers, PM types like to see the blocker count and how that's decreasing.
They would also like to see stuff like "activity". This means comments in bugs
(blocker and non-blocker), new bugs, resolved bugs, nomination queue. Maybe
some lookups like bugs changed in last 4 days. I put the stale bugs view in the
"manager/pm" type category.

Per component it might be interesting to see stats like # blockers, # reviewers available...not sure how you get this info.
Assignee: nobody → mcote

Comment 2

8 years ago
"activity" can be dangerous if it creates a situation where it starts to get gamed by putting meaningless "touches" on the bug just to stay under the radar of a PM watching the query.   

I understand the value of this, but lets think hard about ways to avoid gaming and side effects and test which bugs are getting meaningful updates.

  "reproducible" keyword bugs with with no test case or proposed patch attachments are a set of bugs that might reflect an interesting set bugs to look at that lack of activity and need some help. 

that's a more refined query than "bug has comment added in last X days"

we should spec out some additional queries that reflect states of the bug rather than just added comments.   jesse's "next steps" would be a good set of states to look at.
(Reporter)

Comment 3

8 years ago
I agree. I am not particularly keen on inferring too much information from comments either. Because we don't currently use a true system of "next action" so much of the state of the bug is embedded in the comments. I think that going back to those high level questions is a good place. We are going to work on the developer/team level graphs first, then go back to these higher level tracking graphs to figure out what is needed beyond just the blockers/nomination trends.
(Assignee)

Comment 4

5 years ago
Since (a) this bug is now 2.5 years old, (b) the nature of release tracking has changed since, and (c) I believe there are other efforts completed or under development to do release tracking, I am going to close this bug.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.