Topcrasher byversion links for Firefox 4.0b8pre and 4.0b6 return 500 Internal Server Errors

VERIFIED FIXED in 1.7.5

Status

--
blocker
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: stephend, Assigned: ryansnyder)

Tracking

({regression})

Trunk
1.7.5
regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

I happened to hit this too (testing a different bug), here is the stacktrace from dm-breakpad-stage01:/var/log/httpd/error_log:

Connection to child 1 established (server dm-breakpad-stage01.mozilla.org:443)
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/web/application.py", line 241, in process
    return self.handle()
  File "/usr/lib/python2.4/site-packages/web/application.py", line 232, in handle
    return self._delegate(fn, self.fvars, args)
  File "/usr/lib/python2.4/site-packages/web/application.py", line 395, in _delegate
    return handle_class(f)
  File "/usr/lib/python2.4/site-packages/web/application.py", line 386, in handle_class
    return tocall(*args)
  File "/data/breakpad/processor/socorro/webapi/webapiService.py", line 45, in GET
    raise Exception(stringLogger.getMessages())
Exception: ERROR MainThread Caught Error: exceptions.TypeError
ERROR int argument required
ERROR trace back follows:
  File "/data/breakpad/processor/socorro/webapi/webapiService.py", line 33, in GET    result = self.get(*args)
  File "/data/breakpad/processor/socorro/services/topCrashBySignatureTrends.py", line 228, in get    return twoPeriodTopCrasherComparison(cursor, parameters)
  File "/data/breakpad/processor/socorro/services/topCrashBySignatureTrends.py", line 193, in twoPeriodTopCrasherComparison
    listOfTopCrashers = listOfListsWithChangeInRank(rangeOfQueriesGenerator(databaseCursor, context, listOfTopCrashersFunction))[0]
  File "/data/breakpad/processor/socorro/services/topCrashBySignatureTrends.py", line 135, in listOfListsWithChangeInRank    for i, aListOfTopCrashers in enumerate(listOfQueryResultsIterable):
  File "/data/breakpad/processor/socorro/services/topCrashBySignatureTrends.py", line 109, in rangeOfQueriesGenerator    yield queryExecutio
nFunction(aCursor, parameters)
  File "/data/breakpad/processor/socorro/services/topCrashBySignatureTrends.py", line 69, in getListOfTopCrashersBySignature
    sql = """
See Also: → bug 606994

Updated

8 years ago
Keywords: regression
Assignee: nobody → ryan
Status: NEW → ASSIGNED
I made a minor commit to fix a problem in one of the queries: r2654

The Firefox versions are now resolving properly.  This was resolved by both the query fix, as well as the fact that data has been added to the top_crashes_by_signature table by the tcbs cron job.  (Which illustrates the point that I need to continue working on the updateTopCrashesBySignature.py script to ensure that it catches those data issues when we rollout to production.)

The Fennec problem is caused by that version not being available on stage.

The Thunderbird problem is being caused by a lack of data.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(In reply to comment #5)
> I made a minor commit to fix a problem in one of the queries: r2654
> 
> The Firefox versions are now resolving properly.

Thanks, verified.
 
> The Fennec problem is caused by that version not being available on stage.

Isn't that a spinoff bug, then that it shows up in the UI, despite being unavailable?
 
> The Thunderbird problem is being caused by a lack of data.

What's the next step for resolving this?  File a bug with IT?

Thanks for taking a look at all this, Ryan!
> > The Fennec problem is caused by that version not being available on stage.

Filed bug 608319.
 
> > The Thunderbird problem is being caused by a lack of data.

Filed bug 608309.

Verified FIXED for the original problem.
Status: RESOLVED → VERIFIED
Modifying the update script for production data.

==

Sending        scripts/updateTopCrashesBySignature.py
Transmitting file data .
Committed revision 2667.
(In reply to comment #8)
> Modifying the update script for production data.
> 
> ==
> 
> Sending        scripts/updateTopCrashesBySignature.py
> Transmitting file data .
> Committed revision 2667.

Which of the above in comment 7 will that fix?
@Stephen - This will shape up any data issues that we've seen in stage when we rollout to production.  These will take care of some of the Firefox issues we had originally, which were eventually resolved by the top_crashes_by_signature cron that runs nightly.
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.