build new Firefox Sync page

VERIFIED FIXED

Status

VERIFIED FIXED
8 years ago
6 years ago

People

(Reporter: jslater, Assigned: sgarrity)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [redesign], URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
As part of the site redesign, here's the design file for the new Firefox Sync page. Caitlin can answer any questions about content or what links should go where:

http://www.intothefuzz.com/leetom/Mozilla.com/PSD/mobile_sync_05.psd

Thanks!
(Assignee)

Comment 1

8 years ago
This redesign seems to rely on content for Firefox 4 (since Sync is built in). Should there be a temporary re-skin of the current page for the pre-Fx4 launch of the redesign?
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> This redesign seems to rely on content for Firefox 4 (since Sync is built in).
> Should there be a temporary re-skin of the current page for the pre-Fx4 launch
> of the redesign?

Good question. My understanding is that the page is ok as designed...we'll just need to indicate that the download is for the Fx4 beta in the interim period.

Caitlin, please let us know if that's incorrect. Thanks!
(Assignee)

Comment 3

8 years ago
John, the larger issue is that the page content is built around the assumption that Sync is built into Firefox, rather than an external Add-on, which it isn't yet in 3.6.
(Reporter)

Comment 4

8 years ago
Caitlin, can you address comment #3 and comment #1, then. Here's the page we're discussing for reference:
http://www.intothefuzz.com/leetom/Mozilla.com/JPG/mobile_sync_05.jpg

Comment 5

8 years ago
(In reply to comment #3)
> John, the larger issue is that the page content is built around the assumption
> that Sync is built into Firefox, rather than an external Add-on, which it isn't
> yet in 3.6.

The page is built to push Firefox 4 (beta and GA build). Ragavan and I are under the assumption this page will go live by 12/8. By that time frame, he's confident the Firefox 4 Sync UI will be locked and loaded and we'll be able to push beta while providing an alternative step for 3.5 and 3.6 users.

Comment 6

8 years ago
(In reply to comment #1)
> This redesign seems to rely on content for Firefox 4 (since Sync is built in).
> Should there be a temporary re-skin of the current page for the pre-Fx4 launch
> of the redesign?

No, that's ok. The current Sync page is a temporary page that will continue to receive updates until the Sync UI is locked and loaded. Once that happens, we'll push this page, even if we're pushing Firefox 4 Beta. Thanks!
(Assignee)

Comment 7

8 years ago
Ok, so the download button in Step 1 should be for the Beta, I presume?
(Reporter)

Comment 8

8 years ago
(In reply to comment #7)
> Ok, so the download button in Step 1 should be for the Beta, I presume?

yes.
(Assignee)

Comment 9

8 years ago
This page is now setup in the nova branch (r76664). Ready for review/QA.
(Reporter)

Comment 10

8 years ago
Thanks Steven. Are using that orange button for the beta anywhere else?
(Assignee)

Comment 11

8 years ago
(In reply to comment #10)
> Are using that orange button for the beta anywhere else?

Ah, I should have mentioned that. No, the mockup includes a green download button. I built out this version based on the orange used on http://www.mozilla.com/en-US/firefox/all-beta

The idea behind that orange button was to prevent confusion of the beta with the stable releases. I think that's even more of an issue on a page like this (that isn't a dedicated Beta page).

Feedback is welcome.
(Reporter)

Comment 12

8 years ago
That works for me - just wanted to check and make sure. Content looks good on this page.
Created attachment 487602 [details]
screenshot

Download button and  Sync Icon are broken in IE6.
Keywords: qawanted
(Assignee)

Comment 14

8 years ago
Layout fixed for IE in r76695. As for the download button, the green background is the non-transparent fall-back for the main download button and is built into the PNG. As this isn't a primary page, the issue is only fir IE6 (works fine in IE7+), I'm inclined to leave this. Not because it's more work, but because it adds more hacks/complexity to maintain. Acceptable?
Keywords: qawanted
(Reporter)

Comment 15

8 years ago
I'm fine with that.
(In reply to comment #15)
> I'm fine with that.


qa-verified-trunk http://nova.stage.mozilla.com/en-US/mobile/sync/
Keywords: qawanted
(In reply to comment #14)
> Layout fixed for IE in r76695. As for the download button, the green background
> is the non-transparent fall-back for the main download button and is built into
> the PNG. As this isn't a primary page, the issue is only fir IE6 (works fine in
> IE7+), I'm inclined to leave this. Not because it's more work, but because it
> adds more hacks/complexity to maintain. Acceptable?

Ugly :)  but not a launch blocker, so bug 615378 is low priority.
(Assignee)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
verified fixed http://www.mozilla.com/en-US/mobile/sync/
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.