Closed Bug 606797 Opened 12 years ago Closed 12 years ago

Cursor scales width with height under Ubuntu 10.10

Categories

(Core :: DOM: Editor, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: bugzilla, Unassigned)

References

Details

(Whiteboard: [fixed by bug 389321])

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.2.11) Gecko/20101013 Ubuntu/10.10 (maverick) Firefox/3.6.11 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.2.11) Gecko/20101013 Ubuntu/10.10 (maverick) Firefox/3.6.11 (.NET CLR 3.5.30729)

Under Ubuntu 10.10 (Windows Vista/XP: All fine) the text cursor at the boundary of block elements is scaled both in width and height. That leads to huge blinking blocks, if the cursor is placed at the start or end of a larger block element.

Reproducible: Always

Steps to Reproduce:
1. Open any web page
2. Try to bring the cursor to the boundary of a high block element
3. The cursor is scaled in both width and height
Actual Results:  
See http://static.manuel-strehl.de/StillImage/cursor_scaled.png

Expected Results:  
The cursor should be scaled only in height.
Can you please retest with Firefox4.0b6 or later ?
Yes, remains in FF4b8:
http://static.manuel-strehl.de/StillImage/cursor_ff4.png

By the way: It occurs only with caret browsing enabled.
Additional remarks:

1. In FF4 I tested with a clean, new profile, so no addon is involved

2. I'm running metacity window manager, fully patched Ubuntu 10.10, Intel integrated graphics chip

3. I had an extreme case, where the cursor blinked with some 300x1000px and was layered above the main content of the page, rendering it literally unreadable
Component: General → Editor
Product: Firefox → Core
QA Contact: general → editor
Depends on: 389321
Can you test this in the latest nightly please to see if the same problem still occurs now that bug 389321 has landed?
Seems to be gone with the Nightly (4.0b8pre). Thanks!
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Whiteboard: [fixed by bug 389321]
You need to log in before you can comment on or make changes to this bug.