The debug Viewer Demo #6 (nested tables) doesn't display properly

VERIFIED FIXED in M7

Status

()

P3
normal
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: michaell, Assigned: karnaze)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

20 years ago
This demo appears at first glance to look correct, but when you actually look at table borders and cell borders, there's something very odd going on.  The colors are off, and borders seem to be overlapping.

Comment 1

20 years ago
This is true. The borders look whacky.
Assignee: rickg → karnaze

Comment 2

20 years ago
Created attachment 155 [details]
testcase; multi-row table in rowspanned cell 'confuses' rowspanning

Comment 3

20 years ago
I _think_ the testcase shows a simplified form of what is causing the errors
on the test6.html page. Basically, if there is an inner table in a rowspanned
cell, and the inner table has more than one row, then the rowspanning goes
wrong (the algorithm has the wrong idea about the inner table dimensions).

I cranked up the cellspacing to make the error more apparent (and it bears
no resemblance to the original page).

Comment 4

20 years ago
*** Bug 6223 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
Target Milestone: M7
(Assignee)

Comment 5

20 years ago
fixed with today's checkin.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 6

20 years ago
Fixed in the June 2 Build.

Comment 7

20 years ago
*** Bug 7686 has been marked as a duplicate of this bug. ***

Comment 8

20 years ago
Disregard my previous comment (sorry about spam).
You need to log in before you can comment on or make changes to this bug.