[FIX]modifying style attribute doesn't change .style property for elements not in the document

RESOLVED FIXED in mozilla1.2alpha

Status

()

P1
minor
RESOLVED FIXED
18 years ago
17 years ago

People

(Reporter: giscard.girard, Assigned: bzbarsky)

Tracking

({dom2})

Trunk
mozilla1.2alpha
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

18 years ago
<html><body></body>
<script>
var d = document.createElement("DIV");
d.setAttribute("style","height:50px");
alert(d.style.height);
document.body.appendChild(d);
alert(d.style.height);
</script>
</html>

The first alert in the above example would display "", the second alert would 
display 50px.
To clarify, the expected behavior is that both return 50px.

Confirming bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I see why this is happening, but there are more important problems to fix now so
I'm futuring this for now. Please speak up if you disagree.
Status: NEW → ASSIGNED
OS: Windows NT → All
Hardware: PC → All
Target Milestone: --- → Future
Keywords: dom2
Component: DOM Level 2 → DOM Style
Taking QA Contact on all open or unverified DOM Style bugs...
QA Contact: vidur → ian

Comment 5

18 years ago
*** Bug 69674 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
Created attachment 26140 [details]
testcase from bug 69674
Bumping up the tally of people that have found this to be a problem. 
Created attachment 94813 [details]
Yet another testcase
taking.
Assignee: jst → bzbarsky
Status: ASSIGNED → NEW
Priority: P3 → P1
Target Milestone: Future → mozilla1.2alpha
Comment on attachment 94824 [details] [diff] [review]
Patch to fix

r=jkeiser
Attachment #94824 - Flags: review+
(Assignee)

Updated

17 years ago
Summary: modifying style attribute doesn't change .style property for elements not in the document → [FIX]modifying style attribute doesn't change .style property for elements not in the document
checked in
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Blocks: 162473
You need to log in before you can comment on or make changes to this bug.