Clicking the search button no longer focuses content

RESOLVED FIXED in seamonkey2.1b2

Status

SeaMonkey
Search
--
minor
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Krang, Assigned: Krang)

Tracking

({regression})

Trunk
seamonkey2.1b2
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

1.02 KB, patch
neil@parkwaycc.co.uk
: review+
neil@parkwaycc.co.uk
: superreview+
Details | Diff | Splinter Review
681 bytes, patch
neil@parkwaycc.co.uk
: review+
neil@parkwaycc.co.uk
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

7 years ago
Created attachment 485639 [details] [diff] [review]
Add focus to content

After the patch in bug 410613 was checked in, opening a new tab and clicking the search button on the navigation toolbar no longer gives focus to the content, instead leaving it on the urlbar.  Here is a patch that corrects that.  When looking through the code, I also noticed that our version of loadURI() has different parameters than the one in Firefox, so I also switched it to call gBrowser.loadURIWithFlags() directly.
Attachment #485639 - Flags: superreview?(neil)
Attachment #485639 - Flags: review?(neil)

Comment 1

7 years ago
(From update of attachment 485639 [details] [diff] [review])
Why the try/catch?
(Assignee)

Comment 2

7 years ago
The function definition starting on line 1488 had it, so I copied it over just to be safe.  If it's not needed, though, I can remove it in the next patch.

Comment 3

7 years ago
<!-- throws exception for unknown schemes -->
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/toolkit/content/widgets/browser.xml&rev=1.118&mark=165#165

1.1 <hewitt@netscape.com> 2002-09-27 23:21
165955 - turning on satchel in phoenix
(Assignee)

Comment 4

7 years ago
Created attachment 485662 [details] [diff] [review]
Add focus to content v1.1

Thanks for pointing that out.  It looks like the scheme for the search plugin is already checked in nsSearchService.js, so the try/catch here is unnecessary.  Here is an updated patch.
Attachment #485639 - Attachment is obsolete: true
Attachment #485662 - Flags: superreview?(neil)
Attachment #485662 - Flags: review?(neil)
Attachment #485639 - Flags: superreview?(neil)
Attachment #485639 - Flags: review?(neil)

Comment 5

7 years ago
Comment on attachment 485662 [details] [diff] [review]
Add focus to content v1.1

This is great, but I just noticed that Tools/Search the Web has the same bug, any chance you can fix that version too?
Attachment #485662 - Flags: superreview?(neil)
Attachment #485662 - Flags: superreview+
Attachment #485662 - Flags: review?(neil)
Attachment #485662 - Flags: review+
(Assignee)

Comment 6

7 years ago
Created attachment 485913 [details] [diff] [review]
Add focus for Search the Web

No problem, here is the patch.
Attachment #485913 - Flags: superreview?(neil)
Attachment #485913 - Flags: review?(neil)

Updated

7 years ago
Attachment #485913 - Flags: superreview?(neil)
Attachment #485913 - Flags: superreview+
Attachment #485913 - Flags: review?(neil)
Attachment #485913 - Flags: review+
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
Whiteboard: [c-n: Please check in both patches.]

Comment 7

7 years ago
Pushed to comm-central
http://hg.mozilla.org/comm-central/rev/4a53cb951fc7
http://hg.mozilla.org/comm-central/rev/e7b28bf6559c
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: [c-n: Please check in both patches.]
Target Milestone: --- → seamonkey2.1b2
You need to log in before you can comment on or make changes to this bug.