crash [@ PL_DHashTableOperate | nsTHashtable<nsBaseHashtableET<nsStringHashKey, nsAutoPtr<nsDOMStorageMemoryDB::nsInMemoryItem> > >::RemoveEntry(nsAString_internal const&) ]

RESOLVED DUPLICATE of bug 599341

Status

()

--
critical
RESOLVED DUPLICATE of bug 599341
8 years ago
8 years ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

8 years ago
Build: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101025 Firefox/4.0b8pre

This is a new crash signature that first appeared in b8pre/20101022 build.
It is #5 top crasher in b8pre/20101024 build.
It is probably a dupe of bug 599341, but I write it for traceability.

Signature	PL_DHashTableOperate | nsTHashtable<nsBaseHashtableET<nsStringHashKey, nsAutoPtr<nsDOMStorageMemoryDB::nsInMemoryItem> > >::RemoveEntry(nsAString_internal const&)
UUID	239913f9-95de-4f14-835c-502592101025
Time 	2010-10-25 03:27:57.479376
Uptime	76404
Last Crash	328497 seconds (3.8 days) before submission
Install Age	76404 seconds (21.2 hours) since version was first installed.
Product	Firefox
Version	4.0b8pre
Build ID	20101024042142
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	AuthenticAMD family 16 model 4 stepping 3
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x2c8
App Notes 	AdapterVendorID: 1002, AdapterDeviceID: 68f9

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	PL_DHashTableOperate 	obj-firefox/xpcom/build/pldhash.c:615
1 	xul.dll 	nsTHashtable<nsBaseHashtableET<nsStringHashKey,nsAutoPtr<nsDOMStorageMemoryDB::nsInMemoryItem> > >::RemoveEntry 	obj-firefox/dist/include/nsTHashtable.h:201
2 	xul.dll 	nsObjectFrame::StopPluginInternal 	layout/generic/nsObjectFrame.cpp:2547
3 	xul.dll 	nsObjectFrame::DestroyFrom 	layout/generic/nsObjectFrame.cpp:675
4 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
5 	xul.dll 	nsBlockFrame::DestroyFrom 	layout/generic/nsBlockFrame.cpp:320
6 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
7 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
8 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
9 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
10 	xul.dll 	nsTableFrame::DestroyFrom 	layout/tables/nsTableFrame.cpp:269
11 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
12 	xul.dll 	nsTableOuterFrame::DestroyFrom 	layout/tables/nsTableOuterFrame.cpp:220
13 	xul.dll 	nsBlockFrame::DestroyFrom 	layout/generic/nsBlockFrame.cpp:320
14 	xul.dll 	nsBlockFrame::DestroyFrom 	layout/generic/nsBlockFrame.cpp:320
15 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
16 	xul.dll 	nsCanvasFrame::DestroyFrom 	layout/generic/nsCanvasFrame.cpp:95
17 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
18 	xul.dll 	nsHTMLScrollFrame::DestroyFrom 	layout/generic/nsGfxScrollFrame.cpp:122
19 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
20 	xul.dll 	ViewportFrame::DestroyFrom 	layout/generic/nsViewportFrame.cpp:73
21 	xul.dll 	nsFrameManager::Destroy 	layout/base/nsFrameManager.cpp:253
22 	xul.dll 	PresShell::Destroy 	layout/base/nsPresShell.cpp:2006
23 	xul.dll 	DocumentViewerImpl::DestroyPresShell 	layout/base/nsDocumentViewer.cpp:4271
24 	xul.dll 	DocumentViewerImpl::DestroyPresShell 	layout/base/nsDocumentViewer.cpp:4272
25 	xul.dll 	DocumentViewerImpl::Destroy 	layout/base/nsDocumentViewer.cpp:1618
26 	xul.dll 	DestroyViewerEvent::Run 	docshell/shistory/src/nsSHEntry.cpp:879
27 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:547
28 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:110
29 	xul.dll 	xul.dll@0xb01343 	
30 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:202
31 	xul.dll 	_SEH_epilog4 	
32 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:176
33 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:180
34 	xul.dll 	xul.dll@0xb01343 	
35 	xul.dll 	nsAppShell::Run 	widget/src/windows/nsAppShell.cpp:243
36 		@0x75daffff 	
37 		@0x75aaffff 	
38 	samlib.dll 	TransformMD5 	

More reports at:
http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=&range_value=4&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=PL_DHashTableOperate%20|%20nsTHashtable%3CnsBaseHashtableET%3CnsStringHashKey%2C%20nsAutoPtr%3CnsDOMStorageMemoryDB%3A%3AnsInMemoryItem%3E%20%3E%20%3E%3A%3ARemoveEntry%28nsAString_internal%20const%26%29

Comment 1

8 years ago
A dup, definitely.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 599341
(Assignee)

Updated

8 years ago
Crash Signature: [@ PL_DHashTableOperate | nsTHashtable<nsBaseHashtableET<nsStringHashKey, nsAutoPtr<nsDOMStorageMemoryDB::nsInMemoryItem> > >::RemoveEntry(nsAString_internal const&) ]
You need to log in before you can comment on or make changes to this bug.