Firefox does not launch with error " NS_ENSURE_TRUE(mHiddenWindow) failed: "

RESOLVED WORKSFORME

Status

()

P2
normal
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: sehgal.himanshu01, Assigned: ul-mcamafia)

Tracking

3.5 Branch
PowerPC
AIX
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729) FBSMTWB
Build Identifier:  Firefox-3.5.8

Firefox-3.5.8 fails to launch in AIX with the following error message, it is a debug build in AIX.

*** Registering components in: NSS
*** Registering components in: nsSystemPrefModule
*** Registering components in: nsAutoConfigModule
*** Registering components in: mozSpellCheckerModule
*** Registering components in: nsUnixProxyModule
WARNING: NS_ENSURE_TRUE(mHiddenWindow) failed: file /home/firefox/ffox358_debug/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 396
WARNING: nsExceptionService ignoring thread destruction after shutdown: file /home/firefox/ffox358_debug/mozilla/xpcom/base/nsExceptionService.cpp, line 194

(firefox-bin:1294512): Gtk-WARNING **: cannot open display:  


Display for Firefox is exported on a windows machine with Xmanager.

Reproducible: Always
(Reporter)

Updated

8 years ago
Severity: normal → blocker
OS: Other → AIX
Priority: -- → P2
Version: unspecified → 3.5 Branch
(Assignee)

Comment 1

8 years ago
Can you open a simple "xterm" to your exported display?
If yes, try to start the Firefox from there.
Seems a problem with setting up your X11 server as a first step.

Next question: where do get your Firefox 3.5.8? Seems you're running a debug build and not a release config.

Removing blocker, since you reported against an outdated version 3.5.8, the most recent is 3.5.14, which builds on AIX 5.3 and later without any patches needed.
Severity: blocker → normal
(Reporter)

Comment 2

8 years ago
Ques : Can you open a simple "xterm" to your exported display?

Ans : Could you please specify a xterm that you are referring to.
I am using Xmanger to export DISPLAY to a windows machine.
Even when trying to run xclock with exported display, it fails with the below error message :

<<FIRE>> Checking output for xclock 
Error: Can't open display: 192.168.23.82:0.0


Ques : Seems a problem with setting up your X11 server as a first step.

Ans : Could you please suggest any changes in the X11 server settings to resolve the issue OR may be dig more into the problem and isolate the issue with only X11 server. 
 

Ques : where do get your Firefox 3.5.8? Seems you're running a debug
build and not a release config

Ans : yes I am using the debug build for Firefox-3.5.8 to get more information on the error message as previously it fails with only the above message.
(Assignee)

Comment 3

8 years ago
> <<FIRE>> Checking output for xclock 
> Error: Can't open display: 192.168.23.82:0.0

This proves your X Server setup is severely broken.
If you can start any simple X11 program like xclock or xterm your Firefox will start.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

8 years ago
Please ignore my previous comment.

Have checked it further and xclock and xterm work on the machine with exported display but when tried to run Firefox from xterm window it is failing silently.
(Assignee)

Comment 5

8 years ago
plz paste your mozconfig used for the debug build.
plz paste the output of the command "rpm -qa | sort" for checking the predependencies. 

IBM delivered some severely broken GTK2 rpms in the past. Some of the rpms from Groupe Bull missed 64bit members... Some from IBM the 32bit ones :-(

As a starting point:
use the .mozconfig like the one from:
<http://releases.mozilla.org/pub/mozilla.org/seamonkey/releases/2.0.9/contrib/seamonkey-2.0.9.aix5.1.ppc.README>

On AIX you *must* use the system installed cairo libs instead the in-tree cairo.

You can also try installing
<http://releases.mozilla.org/pub/mozilla.org/seamonkey/releases/2.0.9/contrib/seamonkey-2.0.9-1.aix5.1.ppc.rpm> for verification.
(Reporter)

Comment 6

8 years ago
Created attachment 486036 [details]
.mozconfig file used for the debug build.

The .mozconfig file used for the debug build is attached with this comment
(Reporter)

Comment 7

8 years ago
below is the list of rpms installed on the machine.

#rpm -qa
cdrecord-1.9-7
mkisofs-1.13-4
cairo-1.8.8-1
openssl-0.9.7l-2
atk-1.12.3-2
AIX-rpm-5.3.10.0-11
expat-2.0.1-1
zlib-1.2.3-3
freetype2-2.3.9-1
fontconfig-2.4.2-1
gettext-0.10.40-6
glib2-2.12.4-2
libpng-1.2.32-2
libtiff-3.8.2-1
libjpeg-6b-6
xrender-0.9.1-3
xft-2.1.6-5
pango-1.14.5-4
xcursor-1.1.7-3
pixman-0.12.0-3
gtk2-2.10.6-4
(Assignee)

Comment 8

8 years ago
Created attachment 486037 [details]
Working .mozconfig for AIX

AIX 'till now has no working dbus port. (--disable-dbus)
The accessibility API does not compile with XLC/C++ 7,8 and 9. Don't have 10.1 compiler to verify there. (--disable-accessibility, bug #501924 was never fixed on 3.5 branch).
If you don't use --with-system-zlib you will get macro redefinition errors.
Without --disable-tests building the tests will generate command lines far to long for the AIX shell.

Else use the default.

XFT is working on AIX for years, there only was an issue with the obsolete GXT3000P graphics adaptor.
Assignee: nobody → ul.mcamafia
(Assignee)

Comment 9

8 years ago
I think your machine is missing the devel rpms, if you have built a debug build, there *must* be the headers and pkg-config files not packaged with the runtime-only rpms ???
Your machine is AIX 5.3 TL10, with my .mozconfig you can build a working Firefox 3.5.14 without *any* patch using XLC/C++ 7 with a fixpack of July 2007 or any later IBM compiler/fixpack.
What you describe looks much like the Firefox IBM provides on their site.
-> plz ask IBM for support. They charge big bucks for support contracts.
It's far away from a default Firefox config (no xulrunner build)
(Reporter)

Comment 10

8 years ago
The rpms list provided to you was from the client machine where Firefox is failing to launch. The debug build for Firefox-3.5.8 works fine in other machines with same configuration but it fails only for this machine.
(Assignee)

Comment 11

8 years ago
So you should have a closer look finding the difference between the machine failing and those with "same configuration". Double check runtime pre requirements.
Subtle hint: building *runtime compatible* shared libs isn't a trivial task on AIX.
dump -H (or dump -X 64 -H for 64bit objects) is your friend to track down shared lib dependencies on AIX.
I have written a guide for getting the needed runtime together without breaking Bull's GNOME2. 
<http://www.linkitup.de/ForAIX/Firefox/prereq-moz19.html>

Developer or user?
Have you tried the SeaMonkey 2.0.9 package?
If you really want Firefox/Thunderbird instead of SeaMonkey I can provide you the RPM. I don't publish the Firefox builds because I don't have the permission for using the Firefox brand. They are built from exactly the same source on the same machine with a similar .mozconfig.

Comment 12

8 years ago
The machine where the debug build ran, the display was not exported. Hence the error - (firefox-bin:1294512): Gtk-WARNING **: cannot open display:  

To avoid the above error, one should export the display before running debug build.
You need to log in before you can comment on or make changes to this bug.