crash [@ JSObject::defineProperty(JSContext*, int, js::Value const&, int (*)(JSContext*, JSObject*, int, js::Value*), int (*)(JSContext*, JSObject*, int, js::Value*), unsigned int) ]

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
critical
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: chris hofmann, Unassigned)

Tracking

({crash, regression})

unspecified
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(blocking2.0 beta8+)

Details

(crash signature)

(Reporter)

Description

8 years ago
small residual volume crash thats been around for a while, but another one thats spiked on oct 15.  volume is a bit volatile so daily ranking bounces around.  currently #13 top crash on trunk.  the volume is high enough that we should consider this for b7 blocking.

its also a start up crash with just about all reports inside 30 seconds of start up.

100% windows 7.

stack looks like

http://crash-stats.mozilla.com/report/index/81bc769b-0297-4e36-9409-cd1d52101024

0  	mozjs.dll  	JSObject::defineProperty  	 js/src/jsobj.h:1067
1 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:5919
2 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:638
3 	mozjs.dll 	js::Execute 	js/src/jsinterp.cpp:903
4 	mozjs.dll 	JS_ExecuteScript 	js/src/jsapi.cpp:4726
5 	xul.dll 	mozJSComponentLoader::GlobalForLocation 	js/src/xpconnect/loader/mozJSComponentLoader.cpp:1240
6 	xul.dll 	mozJSComponentLoader::ImportInto 	js/src/xpconnect/loader/mozJSComponentLoader.cpp:1455
7 	xul.dll 	mozJSComponentLoader::Import 	js/src/xpconnect/loader/mozJSComponentLoader.cpp:1367
8 	xul.dll 	nsXPCComponents_Utils::Import 	js/src/xpconnect/src/xpccomponents.cpp:3744
9 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:102
10 	xul.dll 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1752
11 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4625
12 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:638
13 	mozjs.dll 	js::Execute 	js/src/jsinterp.cpp:903
14 	mozjs.dll 	JS_ExecuteScript 	js/src/jsapi.cpp:4726
15 	xul.dll 	mozJSComponentLoader::GlobalForLocation 	js/src/xpconnect/loader/mozJSComponentLoader.cpp:1240
16 	xul.dll 	mozJSComponentLoader::LoadModuleImpl 	js/src/xpconnect/loader/mozJSComponentLoader.cpp:729
17 	xul.dll 	mozJSComponentLoader::LoadModuleFromJAR 	js/src/xpconnect/loader/mozJSComponentLoader.cpp:694
18 	xul.dll 	PL_DHashTableOperate 	obj-firefox/xpcom/build/pldhash.c:625
19 	xul.dll 	nsFactoryEntry::GetFactory 	xpcom/components/nsComponentManager.cpp:1936
20 	xul.dll 	nsComponentManagerImpl::CreateInstanceByContractID 	xpcom/components/nsComponentManager.cpp:1299
21 	xul.dll 	nsComponentManagerImpl::GetServiceByContractID 	xpcom/components/nsComponentManager.cpp:1664
22 	xul.dll 	nsGetServiceByContractIDWithError::operator 	obj-firefox/xpcom/build/nsComponentManagerUtils.cpp:288
23 	xul.dll 	nsAppStartupNotifier::Observe 	embedding/components/appstartup/src/nsAppStartupNotifier.cpp:100
24 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3505
25 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:129
26 	firefox.exe 	__tmainCRTStartup 	obj-firefox/memory/jemalloc/crtsrc/crtexe.c:591
27 	kernel32.dll 	BaseThreadInitThunk 	
28 	ntdll.dll 	__RtlUserThreadStart 	
29 	ntdll.dll 	_RtlUserThreadStart

more reports at

http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=contains&query=JSObject%3A%3AdefineProperty%28JSContext*%2C%20int%2C%20js%3A%3AValue%20const%26%2C%20int%20%28*%29%28JSContext*%2C%20JSObject*%2C%20int%2C%20js%3A%3AValue*%29%2C%20int%20%28*%29%28JSContext*%2C%20JSObject*%2C%20int%2C%20js%3A%3AValue*%29%2C%20unsigned%20int%29&date=10%2F25%2F2010%2006%3A52%3A02&range_value=1&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=JSObject%3A%3AdefineProperty%28JSContext*%2C%20int%2C%20js%3A%3AValue%20const%26%2C%20int%20%28*%29%28JSContext*%2C%20JSObject*%2C%20int%2C%20js%3A%3AValue*%29%2C%20int%20%28*%29%28JSContext*%2C%20JSObject*%2C%20int%2C%20js%3A%3AValue*%29%2C%20unsigned%20int%29

date     tl crashes at, count build, count build, ...
         JSObject::defineProperty.JSContext.,.int,.js::Value.const.,.int.....JSContext.,.JSObject.,.int,.js::Value..,.int.....JSContext.,.JSObject.,.int,.js::Value..,.unsigned.int.   
20101012   
20101013   
20101014 5  3 4.0b8pre2010101304, 
	        2 4.0b62010091408, 
20101015 63  28 4.0b8pre2010101304, 
	        21 4.0b8pre2010101104, 9 4.0b8pre2010101204, 
	        3 4.0b8pre2010100904, 1 4.0b8pre2010101504, 
	        1 4.0b52010083108, 
20101016 4  2 4.0b8pre2010101104, 
	        2 4.0b8pre2010101004, 
20101017 25  17 4.0b8pre2010101304, 
	        6 4.0b8pre2010101204, 2 4.0b8pre2010101104, 
20101018 29  20 4.0b8pre2010101304, 
	        6 4.0b8pre2010100804, 1 4.0b8pre2010101204, 
	        1 4.0b8pre2010101104, 1 4.0b62010091408, 
20101019 61  25 4.0b8pre2010101104, 
	        21 4.0b8pre2010101204, 15 4.0b8pre2010101304, 
20101020 34  16 4.0b8pre2010101204, 
	        13 4.0b8pre2010101104, 4 4.0b8pre2010101304, 
	        1 4.0b62010091408, 
20101021 19  8 4.0b8pre2010100804, 
	        4 4.0b8pre2010101304, 4 4.0b8pre2010101104, 
	        2 4.0b8pre2010101204, 1 4.0b62010091408, 
20101022 11  6 4.0b8pre2010101204, 
	        3 4.0b8pre2010101104, 2 4.0b62010091408, 
20101023 39  21 4.0b8pre2010101104, 
	        8 4.0b8pre2010100804, 6 4.0b8pre2010101304, 
	        2 4.0b8pre2010101204, 1 4.0b8pre2010101004, 
	        1 4.0b62010091408, 
20101024 36  19 4.0b8pre2010100904, 
	        8 4.0b8pre2010101304, 5 4.0b8pre2010101204, 
	        4 4.0b8pre2010101104,
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
Severity: normal → critical
Summary: rash [@ JSObject::defineProperty(JSContext*, int, js::Value const&, int (*)(JSContext*, JSObject*, int, js::Value*), int (*)(JSContext*, JSObject*, int, js::Value*), unsigned int) ] → crash [@ JSObject::defineProperty(JSContext*, int, js::Value const&, int (*)(JSContext*, JSObject*, int, js::Value*), int (*)(JSContext*, JSObject*, int, js::Value*), unsigned int) ]
This may have been fixed by something else; all reports are from older builds.
blocking2.0: ? → beta8+
Has not been seen since the 10/13 build.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ JSObject::defineProperty(JSContext*, int, js::Value const&, int (*)(JSContext*, JSObject*, int, js::Value*), int (*)(JSContext*, JSObject*, int, js::Value*), unsigned int) ]
You need to log in before you can comment on or make changes to this bug.