Add-ons manager completely broken (No add-ons visible)

VERIFIED FIXED in mozilla2.0b8

Status

()

Toolkit
Add-ons Manager
--
critical
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

Trunk
mozilla2.0b8
Points:
---
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(blocking2.0 -)

Details

Attachments

(1 attachment)

1.71 MB, application/force-download
Details
(Reporter)

Description

8 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101024 Firefox/4.0b8pre

Today while verifying some fixes for AOM and ACR I had to switch between different branches of Firefox. Some minutes ago I have noticed that my complete testing profile is broken. There are dozen of errors shown in the error console which clearly state that we have problems with the database.

I will attach the complete testing profile so it should be able to reproduce.
(Reporter)

Comment 1

8 years ago
Created attachment 485738 [details]
Testing profile
(Reporter)

Updated

8 years ago
blocking2.0: --- → ?
Without a way to reproduce this it is going to be difficult to figure out the code error that caused it, however the resulting problem will be fixed by bug 602577
Depends on: 602577
(Reporter)

Comment 3

8 years ago
Well, I know. But I wasn't able to corrupt the profile again. I will report back when I have more information at some point.
(Reporter)

Comment 4

8 years ago
Looks like the database has not been corrupted:

> sqlite> PRAGMA integrity_check;
> ok
No, it just has the wrong schema
Without a confirmed way to reproduce this specific case, and since we are blocking on a bug that will effectively fix the resulting brokenness I don't think we should block on this.
blocking2.0: ? → -
With bug 602577 fixed we should recover from problems like this. It would be nice to find out what causes the problem in the first place but until we do there isn't really anything more to do here.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b8
Backed out due to test failures
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
And relanded
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

8 years ago
The patch on bug 602577 fixed the particular problem with my broken profile. Marking as verified fixed with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101111 Firefox/4.0b8pre
Status: RESOLVED → VERIFIED
Flags: in-testsuite-
Flags: in-litmus-
You need to log in before you can comment on or make changes to this bug.