CSS Border radius doesnt render properly: when using bottom and top border, it isnt smoothened out like it should.

RESOLVED DUPLICATE of bug 500141

Status

()

Core
Layout: Block and Inline
RESOLVED DUPLICATE of bug 500141
8 years ago
8 years ago

People

(Reporter: Kasper, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; nl; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11 ( .NET CLR 3.5.30729; .NET4.0C)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; nl; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11 ( .NET CLR 3.5.30729; .NET4.0C)

When you have a div or something else which you can give a border, and set that border to only show the top and bottom border, thus giving no border to the left and right sides, only the top and bottom borders render.
In Opera 10.63 this is rendered properly: Opera "pulls" the border around the corner, smoothing it out.
But in Firefox 3.6.11 this is rendered wrong: FireFox just makes the border a straight line, with a bit of smooth edges. It also get misaligned with the box: where the border should be.

In the example link you can see a box of 180x150 with a border radius of 25. So there is enough space for the borders to render.

Please look into this.

Reproducible: Always

Steps to Reproduce:
1. Make a box with borders and borderradius.
2. Only show the top and bottom borders.
Actual Results:  
See problem: http://coreper.110mb.com/test/border1.png

Expected Results:  
Smoothen out the borders, like Opera does: http://coreper.110mb.com/test/border2.png
All the links in the bug report are dead, unfortunately...

I'd suggest attaching the test HTML to this bug using the "Add an attachment" link on this bug page.  Please reopen the bug when you do that?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 2

8 years ago
they arent dead, check again.
(Reporter)

Updated

8 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

Comment 3

8 years ago
We have a bug for this
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 500141
(Reporter)

Comment 4

8 years ago
It is more than the borders not aligning properly: they dont curve, as they should.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
> they arent dead, check again.

Yep, looks to be up now.
Created attachment 485799 [details]
The testcase, using 10px borders to make things more obvious
This is indeed a duplicate of bug 500141.  See the testcases there...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 500141
(Reporter)

Comment 8

8 years ago
But again, this ISNT just about the missalignment alone...
As said before, FF doesnt curve the edges like it supposed to. It cuts them straight off, instead of curving them up like it should, and Opera does.
So maybe a partially duplicate, but this issue isnt mentioned in that other thread.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
> But again, this ISNT just about the missalignment alone...

Neither is bug 500141.  Again, the testcases are identical, and render identically.  The only question is what the right behavior is per spec and whether we implement it (the answer to the latter being "no"); the rest is corollaries.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 500141
(Reporter)

Comment 10

8 years ago
Whatever.
You need to log in before you can comment on or make changes to this bug.