If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Since FF 3.6.11 Password & Drop-down Boxes at familiar sites cease working

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Jim, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.11) Gecko/20101012 AskTbDICV5/3.8.0.12304 Firefox/3.6.11 ( .NET CLR 3.5.30729; .NET4.0C)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.11) Gecko/20101012 AskTbDICV5/3.8.0.12304 Firefox/3.6.11 ( .NET CLR 3.5.30729; .NET4.0C)

On same day I upgraded to Thunderbird 3.1.5 & Firefox 3.6.11
- Links in Thunderbird stopped working; which was remedied when I INSTALLED ThunderBrowse;
- But now: Passwords & Drop-down Boxes in familiar sites ceased working. I can't online-bank with Bank of America (the drop-down box requiring location-of-account). My local (books) Library  http://www.cityofsanrafael.org/Government/Library.htm ceased accepting my account password. My customary email-contact to Whitehouse.gov was foiled because the drop-down to several selections won't work.
I'm having to resort to SAFARI for all these kinds of functioning.

Reproducible: Always
(Reporter)

Comment 1

7 years ago
I'm actually finding SAFARI to be a rather smooth browser, when i need resort to it.
Please try http://support.mozilla.com/en-US/kb/Safe+Mode and post steps to reproduce.

For example "I can't online-bank with Bank of America" isn't enough. Which URL, which links must I click, step by step and what isn't working ?
(Reporter)

Comment 3

7 years ago
What are you talking about "Steps To Reproduce"?
It's merely a matter that the use of passwords in many sites, and the function of dropdown boxes as well, as been nullified by the advances-made (I assume there were any) in FF 3.6.11.
Never assume that anyone is seeing your problem. In fact nobody else reported this issue (AFAIK) and the Mozilla QA would find a problem with every dropdown box before Mozilla releases a new build. And there are not only the manual QA tests, every code change is tested with several thousands of automatic tests.
Do you noticed that we have dropdown boxes here in bugzilla and bugzilla is one of the main tools of our developers ?

This would be enough to close this bug report worksforme and send you to the mozilla support (bugzilla is not the support) but I try to help.
Please try the safemode that you already should have tried before reporting a bug and report the results here, thanks
(Reporter)

Comment 5

7 years ago
I actually HAVE NO IDEA, what you're asking me to do.
Go to Safe Mode. AND DO WHAT?
Follow http://support.mozilla.com/en-US/kb/Safe+Mode and start Firefox in the Firefox safemode. You should get a special safemode startup dialog, just proceed without enabling one of the check marks and test a page with your problem.
Report back if it works now or not.
(Reporter)

Comment 7

7 years ago
Yes I started Firefox Mode in Safe, went to https://sitekey.bankofamerica.com/sas/signonSetup.do ; and was able to click through to online banking.
The problem had been only that after the site has my Sign In Name (Username) they then below that would request my click into a drop-in box, whereat to select the state in which my account is. When I'd click @ the drop-down, no selection of states appeared; thus foiling continuance through to online banking.
~~~
Separate Issue: @ https://marinet.lib.ca.us/patroninfo~S3/1351185/top - a public library site - is the message on that pg. : The newest Firefox browsers (v.3.6.11 and 3.5.14) are not allowing people to log into My MARINet.
For now, please use Safari, Internet Explorer or any older version of Firefox. We are sorry for this inconvenience.
~~~
I've found that SAFARI is where to go, while these foibles exist.
Thank you for your patience!
(Reporter)

Comment 8

7 years ago
I don't know what you mean by: "You apparently didn't choose any bugs to modify".
I'd not know how to modify a bug, if it were directly next a flyswatter.
I've clearly stated that the "bug" (wherever the swatter is) is drop-down-box-not-happening. 
And,In FF Safe Mode it DID.
Sorry, I'm not an IT.
It's an installed Firefox addon if it works in the Firefox safemode.
Please open Firefox, click on Tools/Addons/extensions and disable your extensions. One of this extension breaks your Firefox installation.
Restart Firefox and it should work after that and it should work.
You can enable your extensions one by one (if you have more than one installed) to find the one that is causing this bug. Don't forget to restart Firefox after you enabled one addon.
(Reporter)

Comment 10

7 years ago
I'm not following you.
Do you mean that I should disable ea. add-on/then restart FF/consecutively-testing to see which add-on is the culprit?
And, Does This Mean that, thence, FF WILL WORK FIN, ONCE RETARED, & THE ADD-ON IS RE-ENABLED?
Running Firefox in the Firefox safemode disables all installed Firefox extensions only temporary. All addons are enabled again if you start Firefox in the normnal mode. Going to tools/addons/extensions and disabling the extensions will disable them permanent.
(Reporter)

Comment 12

7 years ago
I grasped THAT aspect.
What I DON'T get is:
- am I supposed to - in regular-up FF - 1)individually Disable ea. add-on, 2) then Restart FF, 3) then test the drop-down function; 'til I find the culprit;
- and, then: ONE THAT'S DONE - and re-started - 4?) WILL FF work properly IF THE ADD-ON(S) ARE RE-ENABLED?
a) you start Firefox in the Firefox safemode to check if your problem is caused by the installed extensions
b) you did that and you confirmed that it works in the Firefox safemode = your problem is caused by an extension
c) you start Firefox in the normal mode again and the problem should be there again because all extensions are enabled again. 
d) you disable your extension manually one by one in tools/addons/extension to find the the extension that is causing your problem. You have to restart Firefox after after disabling each extension because the extension is only disabled after a restart. 
e) Once you have found the extension that is causing that you should leave it disabled or uninstall it. 

I don't understand your question.  
> 4?) WILL FF work properly IF THE ADD-ON(S) ARE RE-ENABLED?
You can enable all extensions again except the one that seems to cause your problem. You have to leave it disabled or you can remove/uninstall it.
(Reporter)

Comment 14

7 years ago
(You directions are fairly-clear, appreciably) So:
- After ea. dis-abling of ea. add-on;
- and Re-starting, then;
- once the culprit-add-on is tested as the bady, then;
- THE NON-BAD ADD-ON(S) CAN BE RE-ENABLED?
>>- THE NON-BAD ADD-ON(S) CAN BE RE-ENABLED?
Yes, you can enable them again. I assume that only one extension breaks the drop down box but that is very likely.
(Reporter)

Comment 16

7 years ago
A wee-(problem?):
The 2 sites (Bank of America & The White House) which had required the drop-down box are both functioning!
- B of A, mysteriously, ceased asking the for the State in which my account was (which had a drop-down), and;
- The drop-downs in the White House email-contact form Started Working!
So, I take it, "the deals-off" as far as add-on testing is concerned, 'TIL I FIND A SITE THAT'S STILL REQUIRING THEM & THEY WON'T WORK?
I will mark this report wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.