list tests fail to run with "TypeError: this._keyValueMap is null"

RESOLVED FIXED

Status

Add-on SDK
General
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: myk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
On trunk, the `list` module's tests fail to run with the exception "TypeError: this._keyValueMap is null":

--------------------------------------------------------------------------------
(addon-sdk)myk@myk:~/Projects/addon-sdk/packages/jetpack-core$ cfx test -F list
Using binary at '/home/myk/bin/firefox'.
Using profile at '/tmp/tmpkng6Wg.mozrunner'.

(firefox-bin:4235): GLib-WARNING **: g_set_prgname() called multiple times
Traceback (most recent call last):
  File "resource://jetpack-core-jetpack-core-lib/list.js", line 151, in 
    _iterator: function _iterator(onKeys, onKeyValue) {
  File "resource://jetpack-core-jetpack-core-lib/traits.js", line 151, in compose
    return Composition(_compose.apply(null, traits.map(TraitDescriptor)));
  File "resource://jetpack-core-jetpack-core-lib/traits.js", line 75, in TraitDescriptor
    ) ? object._trait(TraitDescriptor) : _trait(object)
  File "resource://jetpack-core-jetpack-core-lib/traits/core.js", line 136, in trait
    let descriptor = getOwnPropertyDescriptor(properties, key);
  File "resource://jetpack-core-jetpack-core-lib/list.js", line 98, in 
    get length() this._keyValueMap.length,
TypeError: this._keyValueMap is null
No tests were run
FAIL
Total time: 1.430412 seconds
Program terminated unsuccessfully.
--------------------------------------------------------------------------------

It's not a test function that is failing; it's the |require('list')| statement itself.

Irakli: any idea what this might be caused by?
(Reporter)

Comment 1

8 years ago
As with bug 607090, this looks like it is being caused by bug 607278, so marking the dependency.
Depends on: 607278
Duplicate of this bug: 605109
(Reporter)

Updated

8 years ago
Attachment #486336 - Flags: review?(myk) → review+
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

8 years ago
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
You need to log in before you can comment on or make changes to this bug.