Closed Bug 607125 Opened 9 years ago Closed 9 years ago

Jetpack 0.9, Firefox 4b8pre, tabs module errors with "stopiteration"

Categories

(Add-on SDK Graveyard :: General, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 607131

People

(Reporter: KWierso, Unassigned)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: 

When loading the tabs module in an SDK 0.9 addon in Firefox 4b8pre, the following error gets logged to the console:

[object StopIteration]
error: An exception occurred.

Naturally, this prevents the addon from working.

Reproducible: Always

Steps to Reproduce:
1. Import the tabs module into your addon.
2. Load the addon in 4.0b8pre
3. See the error.
Actual Results:  
Error is shown, addon doesn't work.

Expected Results:  
Error is not shown, addon works.
Attached file example testcase
This is a very simple SDK-built addon.
The only thing it includes is "var tabs = require("tabs");
(In reply to comment #1)
> Created attachment 485884 [details]
> example testcase
> 
> This is a very simple SDK-built addon.
> The only thing it includes is "var tabs = require("tabs");

Or at least, it did in Ubuntu using "cfx run -a /path/to/b8pre/firefox".
Not showing the errors when I install the addon over here on Windows...
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 60713
The Add-on SDK is no longer a Mozilla Labs experiment and has become a big enough project to warrant its own Bugzilla product, so the "Add-on SDK" product has been created for it, and I am moving its bugs to that product.

To filter bugmail related to this change, filter on the word "looptid".
Component: Jetpack SDK → General
Product: Mozilla Labs → Add-on SDK
QA Contact: jetpack-sdk → general
You need to log in before you can comment on or make changes to this bug.