Move optional protocols to necko2

VERIFIED DUPLICATE of bug 191970

Status

()

Core
Networking
P3
normal
VERIFIED DUPLICATE of bug 191970
18 years ago
15 years ago

People

(Reporter: dougt, Assigned: Darin Fisher)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
The following protocols should be moved to the optional necko2 shared object:
data, JAR, About, res, keyword.  They shouldn't be needed/required. (there is
some work that needs to be done to make sure that we can get by with only the
file: url.)

We should also promote FTP from the necko2 shared library to necko.  The reason
is that FTP is far more widely used than Finger or DateTime which are in the
same object file.
(Reporter)

Updated

18 years ago
Target Milestone: --- → Future

Comment 1

17 years ago
mass move, v2.
qa to me.
QA Contact: tever → benc
(Reporter)

Comment 2

15 years ago
I think that darin has a patch that will do just something very similar to 
this - it will allow the embedder to enable only the protocols that they 
require.
Assignee: dougt → darin
Target Milestone: Future → ---
(Assignee)

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 191970 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
VERIFIED/dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.