Last Comment Bug 607251 - Aero broken when switch Basic/Aero Theme while minimize/un-minimize window
: Aero broken when switch Basic/Aero Theme while minimize/un-minimize window
Status: VERIFIED FIXED
: regression
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: mozilla10
Assigned To: Brian R. Bondy [:bbondy]
:
: Jim Mathies [:jimm]
Mentors:
: 621857 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-26 01:02 PDT by pal-moz
Modified: 2012-12-06 04:31 PST (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
screenshot (17.86 KB, image/jpeg)
2010-10-26 01:02 PDT, pal-moz
no flags Details
Screenshot of the Firefox bar going black (80.68 KB, image/png)
2010-12-27 05:01 PST, Konomi
no flags Details
ScreenshotOnAurora5.0.a2 (210.91 KB, image/png)
2011-04-18 08:18 PDT, AndreiD[QA]
no flags Details
Screenshot of bug that is still present in v6.0.2 (151.20 KB, image/png)
2011-09-07 13:43 PDT, Konomi
no flags Details
Patch for fixing minimized window and theme change (5.04 KB, patch)
2011-09-07 18:18 PDT, Brian R. Bondy [:bbondy]
jmathies: review+
Details | Diff | Splinter Review

Description pal-moz 2010-10-26 01:02:50 PDT
Created attachment 486013 [details]
screenshot

[STR]
1) start Minefield, with (Windows 7) Basic Theme
2) minimize
3) switch to Aero Theme
4) un-minimize
5) Aero broken (see screenshot)
Comment 1 Jim Mathies [:jimm] 2010-10-26 05:11:39 PDT
A resize or even just a simple mouse over will trigger a full repaint. I see a similar effect with the menu bar enabled, although for some reason as soon as the window restores the paint triggers.
Comment 2 Jim Mathies [:jimm] 2010-11-11 07:50:05 PST
This appears to be fixed in the latest nightly. Pal-moz, can you confirm?
Comment 3 pal-moz 2010-11-11 15:19:42 PST
(In reply to comment #2)
> This appears to be fixed in the latest nightly. Pal-moz, can you confirm?

seems to be partially fixed.
but still broken for a while, about 1/5 - 1/4 seconds

I think this will be completely fixed by backout of bug 593950 . (this happened after/around this bug checkin)
Comment 4 Konomi 2010-12-27 05:01:49 PST
Created attachment 499819 [details]
Screenshot of the Firefox bar going black
Comment 5 Konomi 2010-12-27 05:03:17 PST
(In reply to comment #4)
> Created attachment 499819 [details]
> Screenshot of the Firefox bar going black

Sorry I should've put this in the attachement comments, new to Bugzilla. I'm on Firefox 4 Beta 8 and having the same problem. Here's my User Agent string:

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8) Gecko/20100101 Firefox/4.0b8
Comment 6 Konomi 2011-02-03 21:50:30 PST
This is still happening on the latest nightly but far less.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11pre) Gecko/20110202 Firefox/4.0b11pre
Comment 7 AndreiD[QA] 2011-04-18 08:17:58 PDT
Reproducible on:
Mozilla/5.0 (Windows NT 6.1; rv:5.0a2) Gecko/20110417 Firefox/5.0a2

On the above build, the menu bar is not black anymore but transparent. But I suppose it address the same issue. Attached some screenshots.
Also, I am considering duping bug 621857 after this one, since has not yet been confirmed and was logged later
Comment 8 AndreiD[QA] 2011-04-18 08:18:43 PDT
Created attachment 526732 [details]
ScreenshotOnAurora5.0.a2
Comment 9 AndreiD[QA] 2011-04-19 01:25:13 PDT
*** Bug 621857 has been marked as a duplicate of this bug. ***
Comment 10 Konomi 2011-09-07 13:43:50 PDT
Created attachment 558940 [details]
Screenshot of bug that is still present in v6.0.2

Added this to show the bug is still hanging around in v6 of the browser.
Comment 11 Brian R. Bondy [:bbondy] 2011-09-07 18:18:40 PDT
Created attachment 559019 [details] [diff] [review]
Patch for fixing minimized window and theme change

The main thing that fixes the problem is passing in erase background when invalidating.  It is done synchronously to fix the problem sooner than later as it's a very infrequent message. 

I do this in both WM_DWMCOMPOSITIONCHANGED and WM_THEMECHANGED.

I would have changed the other Invalidate overload as well to have matching parameters, but that overload is part of nsIWidget so I didn't change it.

I'm using ::RedrawWindow instead of ::Invalidate now but as far as I can tell from MSDN the default functionality stays the same.
Comment 12 Brian R. Bondy [:bbondy] 2011-09-29 07:37:29 PDT
Review ping
Comment 13 Konomi 2011-09-30 14:31:47 PDT
(In reply to Brian R. Bondy [:bbondy] from comment #12)
> Review ping

Unfortunatly I do not know how to review your changes so I am hoping someone else tests it for you, thanks for looking at the issue.
Comment 14 Jim Mathies [:jimm] 2011-10-06 13:26:06 PDT
Comment on attachment 559019 [details] [diff] [review]
Patch for fixing minimized window and theme change

sorry for the delay. I like the new options, might come in handy.
Comment 15 Brian R. Bondy [:bbondy] 2011-10-06 13:49:36 PDT
Thanks for the review :)

Rebased and pushed to try:
https://hg.mozilla.org/try/rev/078ea1948daf
Comment 16 Brian R. Bondy [:bbondy] 2011-10-06 13:52:14 PDT
https://tbpl.mozilla.org/?tree=Try&usebuildbot=1&rev=8145967df486
Comment 17 Brian R. Bondy [:bbondy] 2011-10-07 18:56:02 PDT
Pushed to inbound:
http://hg.mozilla.org/integration/mozilla-inbound/rev/ba387863cf06
Comment 18 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-10-09 07:37:01 PDT
https://hg.mozilla.org/mozilla-central/rev/ba387863cf06
Comment 19 Ioana (away) 2011-10-10 00:51:58 PDT
Verified as fixed on:
Mozilla/5.0 (Windows NT 6.1; rv:10.0a1) Gecko/20111009 Firefox/10.0a1

This issue doesn't reproduce anymore using the steps in the bug description.
Comment 20 Petja Touru 2012-12-06 04:18:10 PST
Having this bug on
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20121128 Thunderbird/19.0a2
Comment 21 pal-moz 2012-12-06 04:31:28 PST
(In reply to Petja Touru from comment #20)
> Having this bug on
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20121128
> Thunderbird/19.0a2

file a new bug.

Note You need to log in before you can comment on or make changes to this bug.