Closed Bug 607367 Opened 9 years ago Closed 9 years ago

custom lib loader doesn't work on Galaxy S w/2.2

Categories

(Core :: Widget: Android, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
fennec 2.0b2+ ---

People

(Reporter: vlad, Assigned: mwu)

Details

Attachments

(1 file)

On startup with build FROYO.UCJI6, I get:

E/GeckoLibLoad(6122): Couldn't load lib/libplc4.so because Cannot load library: alloc_mem_region[897]: OOPS: 6122 cannot map library 'libplc4.so'. no vspace available.

for every library except for libxul, where I see:

E/GeckoLibLoad(6122): Couldn't load lib/libxul.so because Cannot load library: link_image[2150]: failed to link libxul.so

then the launcher exits.
tracking-fennec: --- → ?
tracking-fennec: ? → 2.0b2+
Assignee: nobody → mwu
Vlad, try this patch?
Attachment #486140 - Flags: review?(vladimir)
Attachment #486140 - Flags: review?(vladimir) → review+
Brad checked in this patch for me.

http://hg.mozilla.org/mozilla-central/rev/7f139b721d5f

Now we'll see if it sticks.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Could be this bug be (totally?) related with bug 606194?
(In reply to comment #3)
> Could be this bug be (totally?) related with bug 606194?

This is a similar bug but this fix doesn't help bug 606194.
You need to log in before you can comment on or make changes to this bug.