minefield crash when pressing ctrl+p with an image loaded as the content of the current tab

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: rom1dep, Unassigned)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101026 Firefox/4.0b8pre
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101026 Firefox/4.0b8pre

I think everything is in the summary :
When a picture is loaded and when I press ctrl+p to print it, minefield crashs

Reproducible: Always

Steps to Reproduce:
1.load a picture
2.ctrl+p
Actual Results:  
crash

Expected Results:  
firefox's printing helper to pop up...
Please post a crash ID from about:crashes.
https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report

Comment 2

8 years ago
Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101026 Firefox/4.0b8pre

Works for me in Ubuntu 9.10. Able to print the file.
0 	libpthread-2.11.1.so 	libpthread-2.11.1.so@0x7d3d 	
1 	libcups.so.2 	libcups.so.2@0x26e8a 	
2 	libcrypto.so.1.0.0 	libcrypto.so.1.0.0@0x3c238 	
3 	libcrypto.so.1.0.0 	libcrypto.so.1.0.0@0x171dfc 	
4 	libcups.so.2 	libcups.so.2@0x4a71c 	
5 	libc-2.11.1.so 	libc-2.11.1.so@0x3caf1 	
...

CUPS is crashing, please report it to the CUPS developers.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

8 years ago
Okay then, everything is fine !
Because of a problem with cups, it's normal for firefox to crash...
I admit, it's not PRECISELY your fault but a bug in an underlying lib shouldn't make the whole browser broken...
Shouldn't it be a mechanism somewhere to prevent that ?
No, I'm not angry at all but I'm annoyed to see single line programs making X server to crash, just like X11 drivers producing kernel panics...
okok, I close the off-topic section there :)
have a good day !
Firefox calls the Print API and the cup lib is running in the Firefox process. The Firefox process can't survive a crash in CUPS lib.
It's the same with plugins like flash, java,... 
Firefox4 contains a OOPP (Out-of-process-plugin) Feature that moves some of the plugins like flash into a different process.
The Firefox process will survive a crash from supported and compatible plugins now but not all Plugins are working with that (we have a whitelist).
It's nearly impossible to move all API calls into external processes. Is it too much to expect that a print API call shouldn't crash ?

>single line programs making X server to crash
That's a X bug

Comment 7

8 years ago
romain: so, at some point we might move printing to another process. I'd certainly love to see it.

in the interim, you still have a crash. if you want to do something about it, you need to get a stack trace with symbols for cups libs and file a bug against cups.

https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report#Linux
Component: General → Printing: Setup
Keywords: crash, stackwanted
Product: Firefox → Core
QA Contact: general → printing.setup
Version: unspecified → Trunk
(Reporter)

Comment 8

8 years ago
>>single line programs making X server to crash
>That's a X bug
I know, it's not normal !


Anyway, I understand better now, thanks for these informations !
You need to log in before you can comment on or make changes to this bug.