Can not select custom license as option, always defaults back to first option (Mozilla license)

VERIFIED FIXED in 5.12.2

Status

--
major
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: mr, Assigned: jbalogh)

Tracking

unspecified
5.12.2
x86
Windows 7

Details

(Whiteboard: [5.12.1.5])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: 

I updated our iMacros for Firefox addon today. Normally we have a custom license ("other") but today I noted that it selects the first option (Mozilla license) EVEN IF I select the last option (Other).

Result: https://addons.mozilla.org/en-US/firefox/addon/3863/ displays the wrong license type. 

Plus, the license is displayed in Russian on our addon page.

I set the priority to major, as a wrong license could result to confusion/problems for some users or addon authors.

Reproducible: Always

Steps to Reproduce:
1. Upload (update) an addon and try to select "other" as license type

Note: I could test only with our addon, but assume it is a general bug.



Expected Results:  
Display custom license
(Reporter)

Comment 1

8 years ago
Created attachment 486134 [details]
Screenshot of the wrong license display (plus, it is in Russian)
(Assignee)

Updated

8 years ago
Duplicate of this bug: 606863
(Assignee)

Updated

8 years ago
Assignee: nobody → jbalogh
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → 5.12.2

Comment 3

8 years ago
The problem is not only, that you can't select "other" when you upload a new version, the licenses which are linked on the versions page are also wrong.

As an example you can check the version page of Flashblock or CoolPreviews: https://addons.mozilla.org/en-US/firefox/addon/433/versions/
https://addons.mozilla.org/en-US/firefox/addon/2207/versions/

If you check where the link "custom license" for the different versions points to, you will see that it points to a different license for every version. If you check the custom licenses which are linked, you will see, that they are all empty.

So, this seems to be a general error and could cause pretty serious problems for every add-on author which uses a custom license. Therefore it should be fixed in my opinion as soon as possible. I can see "target milestone" 5.12.2. What's the schedule for this milestone?

Comment 4

8 years ago
> What's the schedule for this milestone?

5.12.2 is scheduled to go live on 11/09.
(Assignee)

Updated

8 years ago
Whiteboard: [5.12.1.5]
(Assignee)

Comment 5

8 years ago
r76329

QA: I tested this on the edit-version page, but we also need to look at new-version and new-addon.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Depends on: 607689
(Assignee)

Updated

8 years ago
No longer depends on: 607689

Comment 6

8 years ago
Filed Bug 607689 - License selection does not stick when creating a new version

Also see, Bug 522386 -  License not carrying over between versions?

I was able to change the license from the edit version page. My license selection  was saved and did not revert to Mozilla license. https://preview.addons.mozilla.org/en-US/firefox/addon/228514/license/20101014

Calling this verified.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 7

8 years ago
This is fixed in prod now.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.