bug 606477 followup: fast path INITELEM for arrays of any size

RESOLVED DUPLICATE of bug 603318

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 603318
7 years ago
7 years ago

People

(Reporter: bhackett, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Bug 606477 has slower handling for array initializers with size above MIN_SPARSE_INDEX as these can be slowified from GC while the array is being constructed.  This should be fixed after bug 603318 lands, unless 603318 lands before 606477 does.

Comment 1

7 years ago
The issue is addressed in the patch for bug 603318.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 603318
You need to log in before you can comment on or make changes to this bug.