shutdown document accessible may stay in cache

RESOLVED FIXED

Status

()

Core
Disability Access APIs
RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: surkov, Assigned: surkov)

Tracking

({access, regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Created attachment 486559 [details] [diff] [review]
patch

there are cases when outerdoc accessible gets shutdown and then it shutdowns the underlying document accessible so that the document accessible isn't removed from cache. This may lead to crashes if we get notifications for shutdown documents from layout (I saw some from ReResolveStyleContext - patch from bug 606125). It's regression from 570275, prior this bug we didn't shutdown the document accessible from outerdoc accessible shutdown because we traversed DOM tree.

I suggest to allow the document to shutdown itself completely and make him to shutdown its subdocuments.
Attachment #486559 - Flags: review?(ginn.chen)
(Assignee)

Updated

8 years ago
Assignee: nobody → surkov.alexander
Status: NEW → ASSIGNED

Comment 2

8 years ago
Comment on attachment 486559 [details] [diff] [review]
patch

Looks correct to me.


+  for (PRUint32 idx = 0; idx < childDocCount; idx++)
+    mChildDocuments.ElementAt(idx)->Shutdown();

mChildDocuments[idx]->Shutdown();
would be easier for reading.
Attachment #486559 - Flags: review?(ginn.chen) → review+
(Assignee)

Comment 3

8 years ago
landed with Ginn's comment addressed - http://hg.mozilla.org/mozilla-central/rev/fe4898e97431
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Keywords: regression

Updated

6 years ago
Depends on: 763935

Updated

6 years ago
No longer depends on: 763935
You need to log in before you can comment on or make changes to this bug.