Last Comment Bug 608013 - Silverlight: Firefox window appears over fullscreen window that is supposed to be fullscreen
: Silverlight: Firefox window appears over fullscreen window that is supposed t...
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: unspecified
: All Windows 7
: -- normal (vote)
: ---
Assigned To: Jim Mathies [:jimm]
:
Mentors:
Depends on: 618683
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-28 10:24 PDT by Sunil
Modified: 2011-08-01 05:59 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments
Log files for Window message traces (2.47 KB, application/x-zip-compressed)
2011-05-10 09:50 PDT, Sunil
no flags Details
Repro files (13.02 KB, application/x-zip-compressed)
2011-05-10 13:59 PDT, Sunil
no flags Details
windows fix v.1 (1.14 KB, patch)
2011-05-11 09:17 PDT, Jim Mathies [:jimm]
bent.mozilla: review+
Details | Diff | Review

Description Sunil 2010-10-28 10:24:01 PDT
Silverlight has a feature that allows a fullscreen window to be pinned to a monitor screen in cases of multi-mon setup. With Firefox 4 Beta 8 with the fullscreen window showing, we put up a dialog asking the user if they want to allow it. Upon returning from this dialog, FireFox 4 out-of-process hosting is bringing the browser window to the front (over top of our full-screen window).  Neither Safari nor Chrome do this when we’re hosted out of process.

Specifically, we’d like FireFox not to bring the browser to the front (unless specifically requested by a user interaction, of course) while the host process has a window open.   Our full-screen window is created at the NSModalPanelWindowLevel, in case it’s necessary to identify it specifically.

I am going to include specific repro steps soon.
Comment 1 Sunil 2010-10-28 10:35:35 PDT
To repro this bug a private drop of Silverlight is needed.
Comment 2 Benjamin Smedberg [:bsmedberg] 2010-10-28 13:22:49 PDT
I don't think this blocks, although we'd take an appropriately safe fix.
Comment 3 Josh Aas 2011-02-08 21:11:14 PST
Sunil - are you still seeing this? I haven't seen any issues with fullscreen in the private builds.
Comment 4 Sunil 2011-02-08 21:19:53 PST
I'll follow up with the bug opener on our side.
Comment 5 trunnell 2011-03-30 09:48:45 PDT
This bug is still occurring with fullscreen mode in Netflix.

It's especially bad when Firefox is maximized.  In this case, the Firefox window turns black and fully obscures the fullscreen video behind it, which can be very confusing.
Comment 6 trunnell 2011-03-30 10:01:53 PDT
This bug is marked as x86_64 Mac OS X but it repros on Windows 7 x64 as well.
Comment 7 Josh Aas 2011-04-07 10:46:52 PDT
I'm not clear on how to reproduce this. I watch Netflix videos in x86_64 Firefox 4 on Mac OS X regularly and have never seen it.

Does reproducing this require a multi-monitor setup? Can somebody give more detailed repro steps?
Comment 8 Josh Aas 2011-04-07 15:16:55 PDT
I can reproduce this only with a multiple monitor setup. I'm not sure sure if this is a bug we should fix or a bug Silverlight should fix. Perhaps they can move up a window level or two to avoid this?
Comment 9 Josh Aas 2011-04-07 15:17:52 PDT
If the fix is on our end then we'll likely need a fix for each platform. Jim - can you look into what is going on in Windows?
Comment 10 Sunil 2011-04-07 18:19:01 PDT
Josh, we had a previous conversation about this bug and you told us that we would have to fix it on our side as the new design puts the onus on plugin-developers to manage fullscreen functionality. We are investigating how we can do that.
Comment 11 Josh Aas 2011-04-07 18:51:33 PDT
Yeah, fullscreen was always something plugins were entirely responsible for, being out-of-process just makes it harder to do. I'm curious as to why our behavior is different with multiple monitors though.
Comment 12 Sunil 2011-05-10 09:50:42 PDT
Created attachment 531355 [details]
Log files for Window message traces
Comment 13 Sunil 2011-05-10 09:51:13 PDT
Our dev noticed that Firefox at some indeterminate point of time, brings itself back to the top. Investigating further he noticed that the windows messages being received were different between Firefox and Chrome. Please find the logs attached for the browsers. 

What he observed was after we close a consent dialog to make the fullscreen window the topmost, the browser window is activated. Then we create and show a new fullscreen window, which causes the browser window to be deactivated in both cases. In firefox4, however, the browser window is reactivated again. I’ve highlighted the message in the log that I believe is responsible.
Comment 14 Jim Mathies [:jimm] 2011-05-10 10:00:57 PDT
We really need a simple test case for this and STR so we can try to reproduce this in a debug environment. I can't do much with message logs.
Comment 15 Sunil 2011-05-10 13:59:02 PDT
Created attachment 531458 [details]
Repro files

Unpack the attached file. 
Open FullScreenPinningTestPage.html in the browser.
Click on the button on top of the page.
A Message box pops up with a title "Do you want to allow this website to stay in fullscreen mode?. Click Yes. 
You should see the fullscreen popup and in Firefox 4, the browser window shows up on top of the Fullscreen window.
Comment 16 Jim Mathies [:jimm] 2011-05-10 14:59:35 PDT
(In reply to comment #15)
> Created attachment 531458 [details]
> Repro files
> 
> Unpack the attached file. 
> Open FullScreenPinningTestPage.html in the browser.
> Click on the button on top of the page.
> A Message box pops up with a title "Do you want to allow this website to
> stay in fullscreen mode?. Click Yes. 
> You should see the fullscreen popup and in Firefox 4, the browser window
> shows up on top of the Fullscreen window.

Thanks Sunil. I can reproduce. We'll dig into this and figure out what's going on.
Comment 17 Josh Aas 2011-05-11 05:27:49 PDT
This bug was originally reported as a Mac OS X bug but seems to have morphed into a Windows bug. I assume that means it affects both platforms?
Comment 18 Jim Mathies [:jimm] 2011-05-11 09:17:08 PDT
Created attachment 531652 [details] [diff] [review]
windows fix v.1

Easy one line patch review. The comment explains the reasoning. I've confirmed in a release build this addresses the problem and also ran this through some focus related tests cases to be sure it didn't break normal behavior.
Comment 19 Sunil 2011-05-11 09:22:01 PDT
Jim, when the changes are approved, can you share out a tryserver build for us to test?

Josh, that is correct this started out as a Mac only issue but we started noticing the same issue in Windows too.
Comment 20 Jim Mathies [:jimm] 2011-05-11 12:59:24 PDT
(In reply to comment #19)
> Jim, when the changes are approved, can you share out a tryserver build for
> us to test?
> 
> Josh, that is correct this started out as a Mac only issue but we started
> noticing the same issue in Windows too.

release try builds should be available here in a few hours:

https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/jmathies@mozilla.com-147e2781d39d/
Comment 21 Jim Mathies [:jimm] 2011-05-13 10:07:41 PDT
http://hg.mozilla.org/mozilla-central/rev/8fab4f313491
Comment 22 Jim Mathies [:jimm] 2011-05-13 10:08:31 PDT
(In reply to comment #19)
> Jim, when the changes are approved, can you share out a tryserver build for
> us to test?
> 
> Josh, that is correct this started out as a Mac only issue but we started
> noticing the same issue in Windows too.

If this is still happening on Mac, lets file a new bug.
Comment 23 Sunil 2011-05-15 11:24:20 PDT
Jim I've created bug https://bugzilla.mozilla.org/show_bug.cgi?id=657231 to track Mac issue.
Comment 24 Teodosia Pop 2011-08-01 05:31:21 PDT
WFM using build identifier: Mozilla/5.0 (Windows NT 6.1; rv:6.0) Gecko/20100101 Firefox/6.0.
Comment 25 George Carstoiu 2011-08-01 05:59:49 PDT
Mozilla/5.0 (X11; Linux i686; rv:6.0) Gecko/20100101 Firefox/6.0

Considering Comment 24 setting status to Verified Fixed. 

Thanks Teodosia for verifying this.

Note You need to log in before you can comment on or make changes to this bug.