nsMsgComposeService is used as contenHandler despite is a service

VERIFIED FIXED

Status

MailNews Core
Composition
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Jean-Francois Ducarroz, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

18 years ago
nsMsgComposeSevice should not be used as a contentHandler by the URL dispatcher
because is a service. The URL dispacher will create an instance of it which is
wrong. The fix is to create a separate interface to be use as content handler
for mailto URL.
(Assignee)

Comment 1

18 years ago
Fixed and checked in
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 2

18 years ago
Jean-Francois, do I need a debug build to verify this?  If not, please provide 
me with steps to test this.  Thanks!
(Assignee)

Comment 3

18 years ago
There is no way to test this, was just a coding matter that could be the cause
of problem. Just test that we haven't break anything with this fix. Test mailto
url, and mozilla -compose

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 4

18 years ago
Using builds 3-5-01 on winme, linux and mac basic testing of mailto: and
composing messages is OK.  Verified.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.