Closed Bug 608041 Opened 10 years ago Closed 8 years ago

ldap autocomplete requests lose key presses when server response is slow

Categories

(Thunderbird :: Message Compose Window, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: WSourdeau, Unassigned)

Details

(Whiteboard: [has protocol log][solved with TB 10 ESR and ffffffffffmatching Sogo connectors])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/534.3 (KHTML, like Gecko) Chrome/6.0.472.62 Safari/534.3
Build Identifier: 3.1.6

When slowly typing the first characters of a contact from a remote directory (CardDAV or LDAP), the characters typed while the search is in progress are lost when the search has completed.

This is very painful for our users.

Reproducible: Always
Wolfgang, can you say where is exactly you are typing characters in address book or when composing new email TO: field?
(In reply to comment #1)
> Wolfgang, can you say where is exactly you are typing characters in address
> book or when composing new email TO: field?

Hi Nicolay,

It's during mail composition, in the header fields.
Never experienced with LDAP such problems or maybe not fully understand how this exactly looks like. Can you attach screenshots as examples?
(In reply to comment #3)
> Never experienced with LDAP such problems or maybe not fully understand how
> this exactly looks like. Can you attach screenshots as examples?

I could probably attach a video, yes...

Regarding LDAP, you need to make sure your LDAP repository has thousands of records. The issue will of course not be visible if the resultset is returned fast.
Alternativaly, you could also try to "bottleneck" your LDAP connection with an bandwidth shaper (for example iprelay).
We see this problem too, when the ldap server is responding slowly. (Either due to heavy load or sitting "on the other side of the internet").
Myself and several other users of Thunderbird v 3.1 are reporting problems when entering in an email address when composing a new mail (we have cardav and LDAP addressbook)

If the email is not already stored in our address book, and we're composing a new email to a new recipient, every other key press fails to produce a letter. So if I type, "foo@bar.com" I will have to type "f" then "o" twice for the o to show up and then for every subsequent letter it is like that. Thunderbird lose letters.

More quick composing and more press fails.
Fix this behaviour please!
Myself and several other users of Thunderbird v 3.1 are reporting problems when entering in an email address when composing a new mail (we have cardav and LDAP addressbook)

If the email is not already stored in our address book, and we're composing a new email to a new recipient, every other key press fails to produce a letter. So if I type, "foo@bar.com" I will have to type "f" then "o" twice for the o to show up and then for every subsequent letter it is like that. Thunderbird lose letters.

More quick composing and more press fails.
Fix this behaviour please!
please attach protocol log using
  timestamp,ldap:5 

https://wiki.mozilla.org/MailNews:Logging
Summary: autocomplete requests lose key presses → autocomplete requests lose key presses when server response is slow
Whiteboard: [need protocol log]
I did some extensive tests, but nothing is logged in the ldap trace.
The reason for this seems to be, that the address book query is not sent via ldap, but instead via http(s) to the server.

When I edit the ldap address book settings, then I see a http(s) connection. (Beside this, on sogo servers the ldap port is normaly no available from the internet, everything goes via http(s)

See attached printscreen
Turning on http logging gives awfull lot of data (Since all the webdav calendar traffic is also logged)

WOuld it be helpful to post it here ?
(In reply to comment #11)
> Turning on http logging gives awfull lot of data (Since all the webdav calendar
> traffic is also logged)
> 
> WOuld it be helpful to post it here ?

What do you think the http log might reveal ? (do you do ldap over http ?)
When the URL of the address book is:

https://myserver/SOGo/dav/myeimail@mydomain.com/Contacts/public/

then I assume it is CarDAV which is going via https... ?
In the attached log I did enter the following for the autocomplete:

I typed: tinting
The autocomplete started to search for "tint" and did loss the "ing" keys.

The search started with this line in the log (At line 798):

-1217296240[b750f060]: rdfserv get-resource moz-abmdbdirectory://abook-1.mab?(or(DisplayName,bw,tint)(FirstName,bw,tint)(LastName,bw,tint)(NickName,bw,tint)(and(IsMailList,=,TRUE)(Notes,bw,tint)))

The last log entries matching the search expression are at lines 82200-82203

-1217296240[b750f060]: rdfserv unregister-resource [a7b03360] moz-abmdbdirectory://abook-1.mab?(or(DisplayName,bw,tint)(FirstName,bw,tint)(LastName,bw,tint)(NickName,bw,tint)(and(IsMailList,=,TRUE)(Notes,bw,tint)))
-1217296240[b750f060]: rdfserv unregister-resource [a7b03440] moz-abmdbdirectory://abook-1.mab?(or(PrimaryEmail,bw,tint)(SecondEmail,bw,tint))
-1217296240[b750f060]: rdfserv unregister-resource [a7b03520] moz-abmdbdirectory://abook-4.mab?(or(DisplayName,bw,tint)(FirstName,bw,tint)(LastName,bw,tint)(NickName,bw,tint)(and(IsMailList,=,TRUE)(Notes,bw,tint)))
-1217296240[b750f060]: rdfserv unregister-resource [a7b03600] moz-abmdbdirectory://abook-4.mab?(or(PrimaryEmail,bw,tint)(SecondEmail,bw,tint))

Does this help identify the problem or can I provide other details ?
Whiteboard: [need protocol log] → [has protocol log]
Nikolay, anything useful in the log?
My issue where i saw lots of lost key presses and general instability and tardiness in response when using Thunderbird 3.1 and a card dav addressbook ie SOGo 1.3.11 seems to have gone now I'm using Thunderbird 10ESR and latest SOGo connectors ie inverse sogo connector and Integrator 10.0. Also using Mozilla Lightning 1.2.1.
For this one is also solved with TB 10 ESR and the matching Sogo connectors...
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Summary: autocomplete requests lose key presses when server response is slow → ldap autocomplete requests lose key presses when server response is slow
Whiteboard: [has protocol log] → [has protocol log][solved with TB 10 ESR and ffffffffffmatching Sogo connectors]
You need to log in before you can comment on or make changes to this bug.