Closed Bug 608118 Opened 11 years ago Closed 11 years ago

Firefox/4.0b8pre crash in [@ js::detail::HashTable<unsigned int const, js::HashSet<unsigned int, js::AtomHasher, js::SystemAllocPolicy>::SetOps, js::SystemAllocPolicy>::prepareHash(JSString* const&) ]

Categories

(Core :: JavaScript Engine, defect)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: marcia, Assigned: dmandelin)

Details

(Keywords: crash, topcrash)

Crash Data

Seen while reviewing crash stats. The crash started appearing using 2010102600 builds. http://tinyurl.com/24onng9 links to all the trunk crashes, which are all Windows.

Frame 	Module 	Signature [Expand] 	Source
0 	mozjs.dll 	js::detail::HashTable<unsigned int const,js::HashSet<unsigned int,js::AtomHasher,js::SystemAllocPolicy>::SetOps,js::SystemAllocPolicy>::prepareHash 	js/src/jshashtable.h:282
1 	mozjs.dll 	js_AtomizeString 	js/src/jsatom.cpp:507
2 	mozjs.dll 	js::mjit::ic::GetElem 	js/src/methodjit/PolyIC.cpp:2059
3 	mozjs.dll 	mozjs.dll@0xf901f 	
4 	mozjs.dll 	js::mjit::EnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:742
5 	mozjs.dll 	CheckStackAndEnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:767
6 	mozjs.dll 	js::mjit::JaegerShot 	js/src/methodjit/MethodJIT.cpp:784
7 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4685
8 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:638
9 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:741
10 	mozjs.dll 	SlowCallFromIC 	js/src/methodjit/MonoIC.cpp:411
11 		@0x6252a96 	
12 	mozjs.dll 	js::mjit::EnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:742
13 	mozjs.dll 	CheckStackAndEnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:767
14 	mozjs.dll 	js::mjit::JaegerShot 	js/src/methodjit/MethodJIT.cpp:784
15 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4685
16 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:638
17 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:741
18 	mozjs.dll 	SlowCallFromIC 	js/src/methodjit/MonoIC.cpp:411
19 		@0x92557d7 	
20 	mozjs.dll 	js::mjit::EnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:742
21 	mozjs.dll 	CheckStackAndEnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:767
22 	mozjs.dll 	js::mjit::JaegerShot 	js/src/methodjit/MethodJIT.cpp:784
23 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:635
24 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:741
25 	mozjs.dll 	js_fun_apply 	js/src/jsfun.cpp:2341
26 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4702
27 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:638
28 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:741
29 	mozjs.dll 	SlowCallFromIC 	js/src/methodjit/MonoIC.cpp:411
30 		@0x6462275 	
31 	mozjs.dll 	js::mjit::EnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:742
32 	mozjs.dll 	CheckStackAndEnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:767
33 	mozjs.dll 	js::mjit::JaegerShot 	js/src/methodjit/MethodJIT.cpp:784
34 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:635
35 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:741
36 	mozjs.dll 	js::ExternalInvoke 	js/src/jsinterp.cpp:856
37 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:4933
38 	xul.dll 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:2175
39 	xul.dll 	nsGlobalWindow::RunTimeout 	dom/base/nsGlobalWindow.cpp:8916
40 	xul.dll 	nsGlobalWindow::TimerCallback 	dom/base/nsGlobalWindow.cpp:9261
41 	xul.dll 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:425
42 	xul.dll 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:517
43 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:547
44 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:134
45 	xul.dll 	xul.dll@0xb004cb 	
46 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:202
47 	kernel32.dll 	NlsConvertIntegerToString 	
48 	xul.dll 	_SEH_epilog4
I can seemingly reproduce this on demand by playing music on rdio.com, after updating today's TM nightly from that of a few days ago.  I can't reproduce it on today's MC, though, so that should help narrow it down! (Windows 7, 32 bit build on 64-bit OS.)
blocking2.0: --- → ?
It is #6 top crasher in 4.0b8pre for the last week.
Keywords: topcrash
Mike, marcia was unable to reproduce this. Can you still report on the trunk? What about beta7?
Nay, I cannot.  I play rdio happily on both my nightly builds now (m-c/tm).  Good news for me, but is it generally going away?
Assignee: general → dmandelin
blocking2.0: ? → betaN+
This is lower on the list for 4.08pre because of all those explosive crashes at the top of the list. If this is in the top 10 for beta8 when it comes out, I think we should try and get it in for beta9.
If you sort crashes by 32-bit build (the only way is to display top crasher by nighlty build), it is #6 top crasher in 4.0b8pre in the latest nightly. 

Here are some comments that can help:
"Problems also in sync, preference error"
"Reloaded my evernote page that kept giving "unknown exception" errors"
"By accessing orkut and double click on the link to see updates mozilla crashed."
Time to say this in the right bug:

OK, we've had a big dropoff in the number of these crashes since the diagnostic for bug 605033 landed, so either

 (a) it got fixed by someone else, or
 (b) that diagnostic is making it crash at a different place, which I'm not
finding in Socorro. (I did search for the sigs of both the functions where I added crashes.)

I backed out that diagnostic because it is not providing us with data on bug 605033. If this bug comes back after that, we have a clue. If not, then this bug has probably been fixed.
Hasn't happened after Nov 19 build.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
Crash Signature: [@ js::detail::HashTable<unsigned int const, js::HashSet<unsigned int, js::AtomHasher, js::SystemAllocPolicy>::SetOps, js::SystemAllocPolicy>::prepareHash(JSString* const&) ]
You need to log in before you can comment on or make changes to this bug.