Closed Bug 608149 Opened 11 years ago Closed 11 years ago

Find In This Message goes to the Quick Filter Bar

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 564328

People

(Reporter: dannyv, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101027 Thunderbird/3.1.6

If I choose Edit->Find->Find In This Message (either via the menu *or* via the Ctrl-F shortcut) then I'm taken to the Quick Filter Bar to input a filter string against all messages.  This happens whether or not I have View->Toolbars->Quick Filter Bar checked or not.  

Note that both Edit->Find->Find In This Message AND View->Toolbars->Quick Filter Bar seem to be mapped to Ctrl-F.  Even so, this behavior occurs with selection via menu as well.

Could possibly be related to https://bugzilla.mozilla.org/show_bug.cgi?id=74620 which is filed against SeaMonkey

Reproducible: Always

Steps to Reproduce:
1.Select a message.
2. Optionally select the body pane
3. Ctrl-F *or* Edit->Find->Find In This Message
Actual Results:  
Input focus goes to Quick Search Bar

Expected Results:  
Some way to input a search string against the message body.  Status bar "find" box a la mozilla is what I would expect, but I can imagine a dialog box as well.
Whiteboard: dupeme
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme
Duplicate of bug: 564328
I'm going to disagree that it's the same as bug 564328.  That seems to say 2 things:  
1) that the functions share a keyboard shortcut and
2) that the keyboard shortcut toggles between them.

My primary issue is that I can see no way to invoke Find In This Message at all.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
so / does nothing when you select a message ?
I still think it's a dup, but not from the above bug.
Whiteboard: dupme
(In reply to comment #3)
> so / does nothing when you select a message ?

work if user select (click) on message header pane. Otherwise in messages pane with preview pane visible don't work.
work as designed in tab\window.
(In reply to comment #2)

> My primary issue is that I can see no way to invoke Find In This Message at
> all.

then do you refer to bug #571280?
(In reply to comment #3)
> so / does nothing when you select a message ?

It's the same as if it's not selected.

(In reply to comment #5)

> work if user select (click) on message header pane. Otherwise in messages pane
> with preview pane visible don't work.
> work as designed in tab\window.

doesn't seem to matter what I have selected.  

(In reply to comment #6)
> 
> then do you refer to bug #571280?

no.  I'm not saying that ctrl-f is broken.  I was just pointing out that it may be related to that, but apparently I've confused matters instead.
---

I've attached 2 screenshots.  attachment 487603 [details] shows the state before.  attachment 487604 [details] shows what happens after I use Edit>Find>Find In This Message and type some text.  Note that I did *not* use Ctrl-F for this, so it shouldn't be confused with the Ctrl-F bugs.
(In reply to comment #8)
> screen shot of tb after Edit>Find>Find in This Message followed by typing
> 'fence'

Yes, that's exactly what bug 564328 is about - the two functions share the same internal command, thus one or the other is executed depending on the context, but not necessarily the one you expect (and in this case it's the other one).

I agree with the others that it's a duplicate; it may look different than the initial description of that other bug, but has the same underlying issue (and additionally, bug 571280 should be solved once bug 564328 is fixed).
Reduping per bug 564328 comment #43.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupme
Duplicate of bug: 564328
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.