Closed Bug 608183 Opened 9 years ago Closed 9 years ago

multitouch pinch zoom regressions: jerky panning; jump on first gesture start

Categories

(Firefox for Android Graveyard :: Panning/Zooming, defect)

defect
Not set

Tracking

(fennec2.0b2+)

VERIFIED FIXED
Tracking Status
fennec 2.0b2+ ---

People

(Reporter: mbrubeck, Assigned: mbrubeck)

References

Details

Attachments

(1 file)

Attached patch patchSplinter Review
Two regressions from bug 605692:

A) The first time you start a pinch zoom gesture, the page immediately jumps to a different zoom level as soon as you start the gesture.  This happens because "this._pinchDelta" is unitialized the first time it's used.  The patch fixes this by initializing it on pinch start.

B) Panning while zooming can be very jerky and feel unresponsive.  This happens because we ignore updates where the zoom change is below a threshold, even if they should pan the center point.  The patch fixes this by ignoring the zoom change in this case, but still allowing panning.
Attachment #486837 - Flags: review?(mark.finkle)
Assignee: nobody → mbrubeck
Blocks: 605692
Status: NEW → ASSIGNED
tracking-fennec: --- → ?
Comment on attachment 486837 [details] [diff] [review]
patch

Simple and straightforward.
Attachment #486837 - Flags: review?(mark.finkle) → review+
tracking-fennec: ? → 2.0b2+
http://hg.mozilla.org/mobile-browser/rev/3f6795993406
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
veirfied FIXED on build:
Mozilla/5.0 (Android; Linux armv71; rv:2.0b8pre) Gecko/20101029 Namoroka/4.0b8pre Fennec/4.0b2pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.