requestLongerTimeout for each test within a test in extensions/test/browser

VERIFIED FIXED in mozilla2.0b7

Status

()

Toolkit
Add-ons Manager
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: rstrong, Assigned: rstrong)

Tracking

Trunk
mozilla2.0b7
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

The patch I'm about to attach makes all of the tests under extensions/test/browser pass locally for me with a windows 7 debug build except for bug 584944 (see bug 584944 comment #47 for details as to why I think that test is still failing).
List of tests that failed on me without the patch. I am quite certain that several of these tests failed due to previous tests failing.
browser/browser_bug581076.js
browser/browser_details.js
browser/browser_discovery.js
browser/browser_install.js
browser/browser_list.js
browser/browser_searching.js
browser/browser_updatessl.js
browser/browser_uninstalling.js

browser-window/browser_bug562890.js
browser-window/browser_bug581076.js
browser-window/browser_bug591465.js
browser-window/browser_bug596336.js
browser-window/browser_details.js
browser-window/browser_globalwarnings.js
browser-window/browser_install.js
browser-window/browser_list.js
browser-window/browser_searching.js
browser-window/browser_uninstalling.js
Created attachment 486876 [details] [diff] [review]
patch rev1

With this patch the only tests that fail (including the xpinstall tests) on my system are
browser/browser_uninstalling.js
browser-window/browser_uninstalling.js

per comment #1 and bug 584944 comment #47 it appears there is more to do for browser_uninstalling.js

Better still is that the only errors for these tests are
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_uninstalling.js | Test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_uninstalling.js | Found a tab after previous test timed out: about:addons
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser-window/browser_uninstalling.js | Test timed out
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser-window/browser_uninstalling.js | Found unexpected add-ons manager window still open

I'm used to getting an extremely long list of failures.
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Attachment #486876 - Flags: review?(dtownsend)
btw: there were a couple of tests that needed the requestLongerTimeout in close_manager for them not to time out. Also, I don't have a preference regarding making the value for the call to requestLongerTimeout a parameter for open_manager / close_manager and am fine with removing it if you prefer.
Couple of notes:
Bug 607821 mentions the timeout in browser_bug581076.js though it isn't obvious that it isn't due to the previous timeout in browser_bug557956.js... it is a separate timeout.

Bug 604136 (browser_bug562890.js) will likely be fixed by this

Looks like increasing the timeout for browser_bug562890.js in bug 604136 fixed it for the tinderbox but it didn't fix it for me.

Bug 607821 (browser_bug557956.js) will likely be fixed by this

Bug 579540 (browser_bug553455.js) might be fixed by this

Bug 603557 (lots of intermittent failures) might be fixed by this

Looks like increasing the timeout for browser_searching.js in bug 585212 fixed it for the tinderbox but it didn't fix it for me.

Looks like increasing the timeout for browser_details.js in bug 593622 fixed it for the tinderbox but it didn't fix it for me.
No longer blocks: 603557
Attachment #486876 - Flags: review?(dtownsend) → review+
Pushed to mozilla-central
http://hg.mozilla.org/mozilla-central/rev/4a093a3d6299
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Flags: in-testsuite+
Flags: in-litmus-
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b7
No longer blocks: 607821
No longer blocks: 604136
No longer blocks: 579540
Verified fixed by check-in.
OS: Windows 7 → All
Hardware: x86 → All
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.