pymake package dies with msys path confusion

RESOLVED DUPLICATE of bug 569365

Status

RESOLVED DUPLICATE of bug 569365
8 years ago
6 months ago

People

(Reporter: khuey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

| pymake package | dies when making the langpack (when you've configured absolutely and are using Windows paths).  Filing so that I remember.

z:\dev\msi-tree\toolkit\locales\l10n.mk:193:0$ /bin/sh /z/dev/msi-tree/build/msys-perl-wrapper z:/dev/msi-tree/config/preprocessor.pl -DOSTYPE=\"WINNT6.1\" -DOSARCH=WINNT -DAB_CD=en-US -DMOZ_LANGPACK_EID=langpack-en-US@firefox.mozilla.org -DMOZ_APP_VERSION=4.0b8pre -DLOCALE_SRCDIR=z:/dev/msi-tree/browser/locales/en-US
-DPKG_BASENAME="firefox-4.0b8pre.en-US.win32" -DPKG_INST_BASENAME="firefox-4.0b8pre.en-US.win32.installer"  -DDLL_PREFIX= -DDLL_SUFFIX=.dll -DBIN_SUFFIX=.exe -D_CRT_SECURE_NO_WARNINGS=1 -D_CRT_NONSTDC_NO_WARNINGS=1 -DHAVE_WINSDKVER_H=1 -DMOZ_MSVC_STL_WRAP__RAISE=1 -DWINVER=0x502 -D_WIN32_WINNT=0x502 -D_WIN32_IE=0x0500
-DMOZ_WINSDK_TARGETVER=0x06010000 -DMOZ_NTDDI_WS03=0x05020000 -DMOZ_NTDDI_LONGHORN=0x06000000 -DMOZ_NTDDI_WIN7=0x06010000 -DHAVE_IO_H=1 -DHAVE_SETBUF=1 -DHAVE_ISATTY=1 -DX_DISPLAY_MISSING=1 -DMOZILLA_VERSION=\"2.0b8pre\" -DMOZILLA_VERSION_U=2.0b8pre -DHAVE_SNPRINTF=1 -D_WINDOWS=1 -DWIN32=1 -DXP_WIN=1 -DXP_WIN32=1 -DHW_THREADS=1 -DSTDC_HEADERS=1 -DWIN32_LEAN_AND_MEAN=1 -DNO_X11=1 -DHAVE_OLEACC_IDL=1 -DHAVE_ATLBASE_H=1 -DHAVE_MMINTRIN_H=1 -D_X86_=1 -DD_INO=d_ino -DNS_ALWAYS_INLINE= -DNS_ATTR_MALLOC= -DNS_WARN_UNUSED_RESULT= -DNS_NORETURN= -DMALLOC_H=\<malloc.h\> -DHAVE_FORCEINLINE=1 -DHAVE_LOCALECONV=1 -DNS_ENABLE_TSF=1 -DMOZ_PHOENIX=1 -DMOZ_BUILD_APP=browser -DMOZ_OFFICIAL_BRANDING=1 -DMOZ_DISTRIBUTION_ID=\"org.mozilla\" -DMOZ_IPC=1 -DIBMBIDI=1 -DMOZ_VIEW_SOURCE=1 -DACCESSIBILITY=1 -DMOZ_JSLOADER=1 -DNS_PRINTING=1 -DNS_PRINT_PREVIEW=1 -DMOZ_OGG=1 -DMOZ_WEBM=1 -DVPX_X86_ASM=1 -DMOZ_WAVE=1 -DMOZ_SYDNEYAUDIO=1 -DMOZ_MEDIA=1 -DMOZ_VORBIS=1 -DMOZ_XTF=1 -DMOZ_CRASHREPORTER=1 -DMOZ_CRASHREPORTER_ENABLE_PERCENT=100 -DMOZ_MATHML=1 -DMOZ_SVG=1 -DMOZ_SMIL=1 -DMOZ_UPDATER=1 -DMOZ_UPDATE_CHANNEL=default -DMOZ_FEEDS=1 -DMOZ_STORAGE=1 -DMOZ_SAFE_BROWSING=1 -DMOZ_URL_CLASSIFIER=1 -DMOZ_DEBUG_SYMBOLS=1 -DMOZ_LOGGING=1 -DNS_TRACE_MALLOC=1 -DMOZ_OMNIJAR=1 -DMOZ_USER_DIR=\"Mozilla\" -DMOZ_ENABLE_LIBXUL=1 -DHAVE_STDINT_H=1 -DMOZ_TREE_CAIRO=1 -DHAVE_UINT64_T=1
-DMOZ_XUL=1 -DMOZ_PROFILELOCKING=1 -DMOZ_RDF=1 -DBUILD_CTYPES=1 -DMOZ_MORKREADER=1 -DMOZ_PLACES=1 -DMOZ_SERVICES_SYNC=1 -DMOZ_APP_UA_NAME=\"\" -DMOZ_APP_UA_VERSION=\"4.0b8pre\" -DMOZ_UA_FIREFOX_VERSION=\"4.0b8pre\" -DMOZ_UA_BUILDID=\"20100101\" -DMOZ_DLL_SUFFIX=\".dll\" -DMOZ_REFLOW_PERF=1 -DMOZ_REFLOW_PERF_DSP=1  -Iz:/dev/msi-tree/toolkit/locales/en-US/defines.inc -Iz:/dev/msi-tree/browser/locales/en-US/defines.inc z:/dev/msi-tree/browser/locales/generic/install.rdf > ../../dist/xpi-stage/locale-en-US/install.rdf
Couldn't open /z/dev/msi-tree/obj-i686-pc-mingw32/browser/locales/z:/dev/msi-tree/browser/locales/generic/install.rdf: No such file or directory
(Switching to preprocessor.py fixes this for me)
Attachment #486890 - Flags: review?(ted.mielczarek)
(I didn't remove it from the tree in case comm-central uses it; we can handle that later.)
Dupe of bug 569365 ?
In solution if nothing else.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 569365
Attachment #486890 - Flags: review?(ted.mielczarek)

Updated

6 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.