Firefox should register itself to handle .xpi files

RESOLVED WORKSFORME

Status

()

Firefox
File Handling
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: Chris Pepper, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_4; en-us) AppleWebKit/533.18.1 (KHTML, like Gecko) Version/5.0.2 Safari/533.18.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10

I downloaded firesheep.xpi, and double-clicked on it. Firefox did not register itself as a handler for .xpi files, so I had to switch from "Recommended Applications" to "All Applications" in the app picker, and then select Firefox.

Reproducible: Always

Steps to Reproduce:
Double-click a .xpi file.
Actual Results:  
Mac does not know how to handle it.

Expected Results:  
Mac should pass the .xpi file to Firefox.

Comment 1

7 years ago
Workaround: Drag the link directly from the page to the Tools -> Add-ons dialog.

Comment 2

7 years ago
Is this a duplicate of bug 313468 or not(being a different OS)?
(Reporter)

Comment 3

7 years ago
It looks like bug 313468 is conceptually the same problem, but the fix will be entirely different code/configuration on Mac vs. Windows, so I would avoid marking one as a duplicate. But yes, that discussion is relevant here.

The full workaround is to open an .xpi file, choose the option to specify a helper, click App Applications, select Firefox. Or a similar path via the Finder's Get Info window.

And there is no conflict with Thunderbird, fortunately. The Finder is smart enough to handle 2 different available helpers for a type.
WFM, due to the fact that the workaround from comment 1 is available.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.