tree-management forum messages not getting through from mail to news

RESOLVED FIXED

Status

Release Engineering
General
--
major
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: gerv, Assigned: catlee)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
In bug 608224, comment 6, bz wrote:

> http://groups.google.com/group/mozilla.dev.tree-management/msg/ebc9772daa6d7d89

Very interesting.  As far as my Thunderbird knows, the
mozilla.dev.tree-management newsgroup does not have this message.  

It also doesn't know about these:

http://groups.google.com/group/mozilla.dev.tree-management/browse_thread/thread/395b3155c6d570e0#
http://groups.google.com/group/mozilla.dev.tree-management/browse_thread/thread/165266c3ab775c74#
http://groups.google.com/group/mozilla.dev.tree-management/browse_thread/thread/d25862bd4f919d75#

(it can see some of the _replies_ to some of these messages, but not the
messages themselves).  I wonder who else is not getting these messages....


The message in question entered the system as an email.

This is important because people watch this group to see performance regressions and deal with them.

Gerv

Updated

7 years ago
Assignee: server-ops → justdave
From the headers of those messages:

Content-Transfer-Encoding: base64

I suspect his is why it didn't show up on Giganews.  These are text-only groups, and Giganews doesn't allow attachments.  The entire email was encoded as an attachment.
I think catlee's been generating these, yes? Should be assigned to him.
Assignee: justdave → catlee
Component: Server Operations → Release Engineering
QA Contact: mrz → release
(Assignee)

Comment 3

7 years ago
Boo.  Don't we have any way of having giganews accept these?
Not send them as attachments?
(Assignee)

Comment 5

7 years ago
They're not...they're just base64 encoded messages.
OK, can we not base64-encode them?
(Assignee)

Comment 7

7 years ago
Ok, I've set them up to be ascii encoded, which means losing some Unicode characters for now...unless I can figure out if mail/news supports some kind of unicode encoding that doesn't rely on base64.
UTF-7?
I think the normal way is http://en.wikipedia.org/wiki/Quoted-printable
(Assignee)

Comment 10

7 years ago
Fixed now I think.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.