Random crash in liblocalmail.so

VERIFIED FIXED

Status

MailNews Core
Backend
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: cls, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
My browser crashed with the following error message:

/mozilla-bin: error in loading shared libraries:
/usr/cls/src/obj-opt-O/dist/bin/components/liblocalmail.so: undefined symbol:
memcpy, version 3nsUInt32ArrayUi

The crash seems a bit odd because I was sure that I had closed the mailnews
window and then immediately flipped to another virtual workspace. When I came
back, mozilla was gone.

A grep shows that there's one place in mailnews/local that uses memcpy instead
of nsCRT::memcpy, mailnews/local/src/nsPop3Sink.cpp , but I'm not sure how I
would have ended up in nsPop3Sink as I only use IMAP.
(Assignee)

Comment 1

18 years ago
Created attachment 19576 [details] [diff] [review]
potential fix (use nsCRT::memcpy)
(Assignee)

Comment 2

18 years ago
cc'ing bienvenu for a super review. While I can't trigger the crash either we
should certainly be using nsCRT::memcpy and not memcpy. It can't hurt and it may
just fix this crash that cls sees.

Comment 3

18 years ago
can't hurt, sr=bienvenu
(Assignee)

Comment 4

18 years ago
fix checked in. 
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
No regression reported, fix checked in, VERIFIED.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.