Memory leak in xpcom/typelib/xpidl/xpidl_idl.c in method new_input_data

RESOLVED WONTFIX

Status

()

Core
XPCOM
RESOLVED WONTFIX
7 years ago
6 years ago

People

(Reporter: Karel Rank, Assigned: Karel Rank)

Tracking

({mlk})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/534.10 (KHTML, like Gecko) Chrome/8.0.552.18 Safari/534.10
Build Identifier: 

If there is error during reading from input file, then buffer used for reading from input file is not freed -> memory leak

Reproducible: Always
(Assignee)

Comment 1

7 years ago
Created attachment 486955 [details] [diff] [review]
Free buffer before returning from new_input_data in pcom/typelib/xpidl/xpidl_idl.c

Updated

6 years ago
Duplicate of this bug: 676184

Updated

6 years ago
Keywords: mlk

Updated

6 years ago
Attachment #486955 - Flags: review?(ted.mielczarek)
Comment on attachment 486955 [details] [diff] [review]
Free buffer before returning from new_input_data in pcom/typelib/xpidl/xpidl_idl.c

I'm not actually an XPCOM peer, sorry.
Attachment #486955 - Flags: review?(ted.mielczarek) → review?(benjamin)
Assignee: nobody → karel.rank

Comment 4

6 years ago
Comment on attachment 486955 [details] [diff] [review]
Free buffer before returning from new_input_data in pcom/typelib/xpidl/xpidl_idl.c

This code is being imminently removed, so this is probably not worth the time to get landed. It's a build tool anyway, so this won't affect the product at all.
Attachment #486955 - Flags: review?(benjamin)

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.