Loading Top Crashers By in one product populates the Versions pulldown with Firefox version numbers

VERIFIED FIXED in 1.7.5

Status

--
major
VERIFIED FIXED
8 years ago
7 years ago

People

(Reporter: stephend, Assigned: ryansnyder)

Tracking

({regression})

1.7.5
regression

Firefox Tracking Flags

(Not tracked)

Details

(URL)

STR:

1. Load http://crash-stats.stage.mozilla.com/products/Fennec
2. Choose "Top Crashers By [domain], [url]" etc.
3. Now, look at the Version pulldown

Expected Results:

Fennec version numbers

Actual Results:

Firefox version numbers
Possibly related fallout?  http://crash-stats.stage.mozilla.com/daily?p=Fennec&v[]=4.0b1 populated Product itself with Firefox, and very clearly pulls Firefox data.
The issue in https://bugzilla.mozilla.org/show_bug.cgi?id=608361#c1 is a separate bug, caused by Fennec not being found in config/daily.php.  Spinning off Bug 608383 for that.
In #0, the product also changes to Firefox.
Okay, this was caused by moving to database session storage in Bug 608023.  Code is looking to access the selected product specifically from cookie; I'll look to see if there is any other code that might be affected as well.
After further investigation, it turns out that this issue is actually being caused by setting the value in config/cookie.php for $config['secure'] to TRUE in Bug 607081. Once $config['secure'] is changed to FALSE, the problem listed above no longer happens.
Depends on: 607081
Fixed issue with chosen version cookie.

==

Sending        application/controllers/auth.php
Sending        application/libraries/MY_Controller.php
Transmitting file data ..
Committed revision 2675.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Verified FIXED; thanks, Ryan.
Status: RESOLVED → VERIFIED
Component: Socorro → General
Product: Webtools → Socorro
You need to log in before you can comment on or make changes to this bug.