browser_bug557956.js | Found unexpected add-ons compatibility window still open followed by browser_bug557956.js | Test timed out

VERIFIED FIXED in mozilla2.0b7

Status

()

Toolkit
Add-ons Manager
VERIFIED FIXED
7 years ago
5 years ago

People

(Reporter: rstrong, Assigned: mossop)

Tracking

({intermittent-failure})

Trunk
mozilla2.0b7
intermittent-failure
Points:
---
Bug Flags:
in-testsuite -
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Looks like a Mac OS X version of Bug 607821. Since Bug 607821 was filed against Windows I'm going to just file a new bug.

Rev3 MacOSX Leopard 10.5.8 mozilla-central opt test mochitest-other on 2010/10/29 15:49:24

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1288392564.1288393629.16604.gz


TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Test 4 took 628ms
*** LOG addons.xpi: Cancelling download of http://example.com/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956_7_2.xpi
*** LOG addons.xpi: Cancelling download of http://example.com/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956_9_2.xpi
*** LOG addons.xpi: Cancelling download of http://example.com/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956_8_2.xpi
*** LOG addons.xpi: Cancelling download of http://example.com/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956_7_2.xpi
*** LOG addons.xpi: Cancelling download of http://example.com/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956_8_2.xpi
*** LOG addons.xpi: Cancelling download of http://example.com/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956_9_2.xpi
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Console message: [JavaScript Warning: "WARN addons.xpi: Add-on addon1@tests.mozilla.org is missing bootstrap method shutdown"]
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Console message: [JavaScript Warning: "WARN addons.xpi: Add-on addon1@tests.mozilla.org is missing bootstrap method uninstall"]
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Console message: LOG addons.xpi: Loading bootstrap scope from /var/folders/Xr/Xr--yJnSEY0U11ET5NZuMU+++TM/-Tmp-/tmp_pnH4F/extensions/addon2@tests.mozilla.org.xpi
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Console message: [JavaScript Warning: "WARN addons.xpi: Error loading bootstrap.js for addon2@tests.mozilla.org: Error opening input stream (invalid filename?)"]
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Console message: [JavaScript Warning: "WARN addons.xpi: Add-on addon2@tests.mozilla.org is missing bootstrap method uninstall"]
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Console message: LOG addons.xpi: Loading bootstrap scope from /var/folders/Xr/Xr--yJnSEY0U11ET5NZuMU+++TM/-Tmp-/tmp_pnH4F/extensions/addon3@tests.mozilla.org.xpi
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Console message: [JavaScript Warning: "WARN addons.xpi: Error loading bootstrap.js for addon3@tests.mozilla.org: Error opening input stream (invalid filename?)"]
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Console message: [JavaScript Warning: "WARN addons.xpi: Add-on addon3@tests.mozilla.org is missing bootstrap method uninstall"]
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Console message: [JavaScript Warning: "WARN addons.xpi: Add-on addon4@tests.mozilla.org is missing bootstrap method shutdown"]
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Console message: [JavaScript Warning: "WARN addons.xpi: Add-on addon4@tests.mozilla.org is missing bootstrap method uninstall"]
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Console message: [JavaScript Warning: "WARN addons.xpi: Add-on addon5@tests.mozilla.org is missing bootstrap method shutdown"]
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Console message: [JavaScript Warning: "WARN addons.xpi: Add-on addon5@tests.mozilla.org is missing bootstrap method uninstall"]
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Console message: [JavaScript Warning: "WARN addons.xpi: Add-on addon6@tests.mozilla.org is missing bootstrap method shutdown"]
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Console message: [JavaScript Warning: "WARN addons.xpi: Add-on addon6@tests.mozilla.org is missing bootstrap method uninstall"]
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Console message: LOG addons.xpi: Cancelling download of http://example.com/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956_7_2.xpi
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Console message: LOG addons.xpi: Cancelling download of http://example.com/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956_9_2.xpi
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Console message: LOG addons.xpi: Cancelling download of http://example.com/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956_8_2.xpi
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Console message: LOG addons.xpi: Cancelling download of http://example.com/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956_7_2.xpi
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Console message: LOG addons.xpi: Cancelling download of http://example.com/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956_8_2.xpi
TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Console message: LOG addons.xpi: Cancelling download of http://example.com/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956_9_2.xpi
<a name='err0'></a><font color='000080'>TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | Found unexpected add-ons compatibility window still open
</font>INFO TEST-END | chrome://mochitests/content/browser/toolkit/mozapps/extensions/test/browser/browser_bug557956.js | finished in 3216ms
Summary: /browser_bug557956.js | Found unexpected add-ons compatibility window still open followed by browser_bug557956.js | Test timed out → browser_bug557956.js | Found unexpected add-ons compatibility window still open followed by browser_bug557956.js | Test timed out
Locally I have seen the compatibility window open when other tests were running and Cc / Ci not being defined in the function that opens the compatibility window. This makes me suspect that the call to open is happening after the test has closed. Also, I recently added a check to head.js for the compatibility window and if it is found it closes it.
(In reply to comment #1)
> Locally I have seen the compatibility window open when other tests were running
> and Cc / Ci not being defined in the function that opens the compatibility
> window. This makes me suspect that the call to open is happening after the test
> has closed. Also, I recently added a check to head.js for the compatibility
> window and if it is found it closes it.
Also see bug 608107
Blocks: 438871
Depends on: 608107
Whiteboard: [orange]
The thing I find suspicious is the following:

browser_bug557956.js | Cancelling download of browser_bug557956_7_2.xpi
browser_bug557956.js | Cancelling download of browser_bug557956_9_2.xpi
browser_bug557956.js | Cancelling download of browser_bug557956_8_2.xpi
browser_bug557956.js | Cancelling download of browser_bug557956_7_2.xpi
browser_bug557956.js | Cancelling download of browser_bug557956_8_2.xpi
browser_bug557956.js | Cancelling download of browser_bug557956_9_2.xpi
TEST-UNEXPECTED-FAIL | browser_bug557956.js | Found unexpected add-ons compatibility window still open
INFO TEST-END | browser_bug557956.js | finished in 3216ms

Notice that the each xpi download above is being cancelled twice. Might just be the way it works but it does seem strange.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 17

7 years ago
Created attachment 487991 [details] [diff] [review]
patch rev 1

How about we wait for the compatibility window to close before proceeding with each part of the test?
Assignee: nobody → dtownsend
Status: NEW → ASSIGNED
Attachment #487991 - Flags: review?(robert.bugzilla)
Comment on attachment 487991 [details] [diff] [review]
patch rev 1

Sounds like a good idea! ;)
Attachment #487991 - Flags: review?(robert.bugzilla) → review+
(Assignee)

Comment 19

7 years ago
Landed, maybe fixed?

http://hg.mozilla.org/mozilla-central/rev/734d89f63682
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla2.0b7
No longer depends on: 608107
Duplicate of this bug: 608107
No more failures since the fix has been landed => verified fixed.
Status: RESOLVED → VERIFIED
Flags: in-testsuite-
Flags: in-litmus-
OS: Mac OS X → All
Hardware: x86 → All
Comment hidden (Treeherder Robot)
Keywords: intermittent-failure
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.