Brand Thunder has a link to their privacy policy rather then a statement

RESOLVED DUPLICATE of bug 604222

Status

addons.mozilla.org Graveyard
Policy
P3
minor
RESOLVED DUPLICATE of bug 604222
7 years ago
2 years ago

People

(Reporter: DS, Unassigned)

Tracking

unspecified
5.12.3

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: 

This may be acceptable but it should not be.

When you click on most (if not all, I didn't check) of Brand Thunder's privacy policy buttons it leads to where the privacy policy should be.  However, the policy is not stated there, it simply contains a url that has to be cut and pasted into the address bar in order to view the policy.

Reproducible: Always

Steps to Reproduce:
1.Go to (for example) https://addons.mozilla.org/en-US/firefox/addon/122891/
2. Click on Privacy Policy
3.
Actual Results:  
An unclickable url that needs to be copy and pasted to the address bar to view the policy.

Expected Results:  
Should lead to a statement of the actual policy or the link should be clickable.

Personally, I doubt if anyone is going to go to the trouble of doing everything that needs to be done to get to the policy.
The Privacy Policy field doesn't support HTML, so there's no way to make the link clickable. Arguably that would be the real bug here.

It'd be great if the BT guys pasted the policy contents in that field, but given the amount of add-ons they maintain, I can understand them preferring a link to a central location. mkaply, thoughts?
 
> Personally, I doubt if anyone is going to go to the trouble of doing everything
> that needs to be done to get to the policy.

Somebody interested in reading the policy will most certainly bother. Those who don't probably weren't going to read any of it anyway...
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
(In reply to comment #1)
> The Privacy Policy field doesn't support HTML, so there's no way to make the
> link clickable. Arguably that would be the real bug here.

bug 604222
OK, so let's wait for that and then the BT folks can really link to the policy.
Depends on: 604222
Priority: -- → P3
Target Milestone: --- → 5.12.3

Comment 4

7 years ago
Yeah, the problem is that our privacy policy can change and we don't want to have to keep going back and pasting it in all of our addons.
Let's not keep this bug open if it's going to be fixed with bug 604222.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 604222
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.