existing passwords not properly imported

RESOLVED DUPLICATE of bug 482443

Status

SeaMonkey
Passwords & Permissions
--
major
RESOLVED DUPLICATE of bug 482443
8 years ago
8 years ago

People

(Reporter: Jay White, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.14) Gecko/20100930 SeaMonkey/2.0.9
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.14) Gecko/20100930 SeaMonkey/2.0.9

When upgrading from seamonkey 2.1.18 to seamonkey 2.0.9 the existing password datrabase is not properly imported.  A few entries are imported then there are some garbled entries then the remainder are missing.

Reproducible: Always

Steps to Reproduce:
1. upgrade from seamonkey 1.1.18 to seamonkey 2.0.9
2. check password list
3.
Actual Results:  
A few entries are imported, then there are some garbled entries, then the remainder are missing.

Expected Results:  
Passwords should be properly imported.

If you recompile seamonkey 1.1.8 and enable compilation of the 'pwdecrypt' utility then one can easily verify that pwdecrypt properly decrypts the entire NNNNNN.s file.  So why does seamonkey 2.0.9 get it so wrong?  Such a simple and relatively trivial aspect of an upgrade should not fail so miserably.  One has to manually use pwdecrypt and sed to create a new signons3.txt then delete the corrupt and totally unusable signons.sqlite.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 482443
You need to log in before you can comment on or make changes to this bug.