mozilla segfaults before completing the page load

VERIFIED WORKSFORME

Status

()

P3
major
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: moya, Assigned: rogerl)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
When trying to view the above URL, mozilla (Build ID:2000112021) segfaults. I'm
using Slackware 7.1, Kernel version 2.2.18pre22, i686, 320MB RAM. The page
apparently requires javascript, which I don't understand, you'll have a bit more
luck I hope ;-P

I managed to narrow it down to the following html snippet:

-----------------
<BASE HREF="http://misery.subnet.at/">
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML>
<a target="_top" href="http://u.extreme-dm.com/?login=deaddrea">
<img name=im src="http://u1.extreme-dm.com/i.gif" height=38
border=0 width=41 alt=""></a><script language="javascript"><!--
an=navigator.appName;d=document;function
pr(){d.write("<img src=\"http://u0.extreme-dm.com",
"/0.gif?tag=deaddrea&j=y&srw="+srw+"&srb="+srb+"&",
"rs="+r+"&l="+escape(d.referrer)+"\" height=1 ",
"width=1>");}srb="na";srw="na";//-->
</script><script language="javascript1.2"><!--
s=screen;srw=s.width;an!="Netscape"?
srb=s.colorDepth:srb=s.pixelDepth;//-->
</script><IMG
src="http://u0.extreme-dm.com/0.gif?tag=deaddrea&j=y&srw=1600&srb=24&rs=41&l=http%3A//www.themes.org/php/links.phtml%3Flinkcat%3D5"
height=1 width=1>
</BODY>
</HTML>
----------------
Do you see the crash at the top-level page or deeper in the site?  I can't
reproduce this crash using a CVS mozilla build from the evening of Nov. 20 and
Looking at the source it does not contain the snippet you cite...

Comment 2

18 years ago
The HTML for the given URL is:

<HTML>
<FRAMESET ROWS="*,0" BORDER=0>
<FRAME FRAMEBORDER=NO border=0 framespacing=0 SRC="http://misery.subnet.at"                                                                  
NAME=framesrc>
</FRAMESET>
</HTML>


The HTML Kevin has attached comes from http://misery.subnet.at, but seems 
to be missing a couple lines. I will attach the HTML below, both as text 
and as HTML, with the appropriate <BASE> tag added. 

Comment 3

18 years ago
Created attachment 19564 [details]
The HTML from http://misery.subnet.at/  (saved as text)

Comment 4

18 years ago
Created attachment 19565 [details]
The HTML from http://misery.subnet.at/  (saved as HTML)

Comment 5

18 years ago
I can't reproduce this crash, on either Linux or WinNT. Both the given URL
and the attachment id = 19565 above load just fine, and produce no errors
in the JavaScript console.


Based on this and on Boris' comments above, I'm going to resolve this as
WORKSFORME. Please reopen if this is still not working - thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 6

18 years ago
Marking Verified -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.