Clicking on General tab in Tools -> Options creates an undesired folder at an unspecified location

RESOLVED DUPLICATE of bug 474718

Status

()

Firefox
Preferences
RESOLVED DUPLICATE of bug 474718
8 years ago
8 years ago

People

(Reporter: Oscar Lee, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.12) Gecko/20101026 Firefox/3.6.12

Even after setting a different "Save files to" location and selecting the "Always ask me where to save files" option in Tools -> Options -> General, every time when one goes into the General panel in Options, a "Downloads" folder is created in %UserProfile%\My Documents\.  The folder is not created when one goes to any other panel in Options.

Reproducible: Always

Steps to Reproduce:
1.  In Firefox, go to Tools -> Options -> General.

2.  Check "Show the Downloads window when download a file" and "Close it when all downloads are finished" options.  Select "Save files to" and click on the Browse button to select a non-default location (e.g. %Temp%).  Select "Always ask me where to save files" option, go to any Options panel other than General (e.g. Tabs), and then click on the OK button.

3.  Go to %UserProfile%\My Documents\ in Windows Explorer.  Verify that a "Downloads" folder exists and then delete the folder.  Leave Windows Explorer open.

4.  Go back to Tools -> Options in Firefox, and verify that the Options window shows the previously selected panel (e.g. Tabs).  Keep the Options window open and go back to Windows Explorer.  Verify that there isn't a "Downloads" folder in %UserProfile%\My Documents\.

5.  Go back to the Options window in Firefox, and click on the General panel.  Now go back to %UserProfile%\My Documents\ in Windows Explorer and verify that a "Downloads" folder has been created.
Actual Results:  
An unnecessary "Downloads" folder is created by Firefox in %UserProfile%\My Documents\.

Expected Results:  
No unnecessary folder should have been created.
(Reporter)

Comment 1

8 years ago
Created attachment 487193 [details]
A screenshot of my Options -> General settings
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 474718
You need to log in before you can comment on or make changes to this bug.